LOCKED OUT! Mod_Security Package….Problem? or just a newb....



  • Hello guys.. I don't know if anyone else has had this, and as per the title of my topic, maybe it's just a newb mistake…
    today I installed the package for mod_security in the 1.2.2 package list, and got locked out of Pfsense.  :-[

    "Forbidden

    You do not have access to / on this server"

    how do I allow myself access to my firewall?? ???
    Thanks in advance.



  • Well…. I got in... havn't looked to see if there are any package pref.s yet that I can set up and allow myself access...
    For anyone else who has problems, I used
    /usr/local/sbin/httpd -k stop
    i know, it just stopped the service, but I really had no idea how to do that from the SSH prompt.  Since I didn't know how,
    there are probably others who don't either



  • There's an option under the System–>Advanced tab that warns about lock-out. It says,

    "By default, access to the webGUI on the LAN interface is always permitted, regardless of the user-defined filter rule set. Enable this feature to control webGUI access (make sure to have a filter rule in place that allows you in, or you will lock yourself out!).
    Hint: the "set LAN IP address" option in the console menu resets this setting as well."

    Play around with the various settings under the Miscellaneous heading and I think you'll find the solution.



  • Thanks… If that works better than changing around "deny and allow" rules ill do that... probably safer too... ;D


Log in to reply