Interesting glitch with asterisk



  • So I configure the TS with the static IP of my pbx in a flash box, 10.0.0.7.  Make a few test calls.  Puzzled that inbound traffic was going into qVoipDown, but outbound was going into qWanAcks.  Hmmm.  Google around and find a thread involving scott and bill from a couple of years ago that gave me the necessary clue.  To wit: asterisk sets low delay bit by default, which was causing the outbound traffic to go via qWanAcks.  I guess I don't care, since that is also high priority, but I was feeling anal and wanted to understand what was up.  I changed the asterisk config to set the sip and rtp ToS to 0, reloaded asterisk, and voila :)



  • Could you please share where this can be done in Asterisk? I am having the same problem.

    When I change the setting in sip.conf, Asterisk is showing an error message in the log that it can't set the setting. It seems that Asterisk would have to run as root to do so.

    Thanks,
    Jens



  • The default location for these is in sip_general_additional.conf, but you tweak them in sip_general_custom.conf.  Like this:

    tos_sip=0
    tos_audio=0

    NB: this is for a freepbx-based system.  If yours is not, you need to figure out where to set these for your setup.



  • Thanks! :)

    I just tested it and it works great. I am using Elastix which is FreePBX based. Just switched from trixbox.

    I would think that most people who are using Asterisk will want this to make their traffic shaping efforts easier.

    Cheers,
    Jens



  • @danswartz:

    The default location for these is in sip_general_additional.conf, but you tweak them in sip_general_custom.conf.  Like this:

    tos_sip=0
    tos_audio=0

    NB: this is for a freepbx-based system.  If yours is not, you need to figure out where to set these for your setup.

    Been looking for this solution for a long time. Thanks. Im on the PBXInAFlash asterisk flavor….


Log in to reply