Squid in RC2



  • i am running squid 0.4 in both master and backup server (pfsense RC2 built on Tue Aug 1 18:24:49 UTC 2006)

    the squid services running fine on the master. but in the backup server the squid service will stop automatically. below is the log i obtained from the backup servers (/var/squid/log/cache.log). it show 2 different errors when i manually start the services

    Error #1 - it show that it shut down normally after 0 request

    2006/08/29 11:50:06|  store_swap_size = 548k
    2006/08/29 11:50:06| ipcCreate: /usr/local/libexec/squid/pinger: (13) Permission
    denied
    2006/08/29 11:50:07| Preparing for shutdown after 0 requests

    2006/08/29 11:50:07| Waiting 30 seconds for active connections to finish
    2006/08/29 11:50:07| FD 19 Closing HTTP connection
    2006/08/29 11:50:07| Closing Pinger socket on FD 24
    2006/08/29 11:50:07| storeLateRelease: released 0 objects
    2006/08/29 11:50:38| Shutting down…
    2006/08/29 11:50:38| FD 21 Closing HTCP socket
    2006/08/29 11:50:38| FD 22 Closing SNMP socket
    2006/08/29 11:50:38| Closing unlinkd pipe on FD 18
    2006/08/29 11:50:38| storeDirWriteCleanLogs: Starting...
    2006/08/29 11:50:38|  Finished.  Wrote 183 entries.
    2006/08/29 11:50:38|  Took 0.0 seconds (99133.3 entries/sec).
    CPU Usage: 0.111 seconds = 0.062 user + 0.049 sys
    Maximum Resident Size: 7632 KB
    Page faults with physical i/o: 0
    2006/08/29 11:50:38| Open FD              20 squid -> diskd
    2006/08/29 11:50:38| Squid Cache (Version 2.5.STABLE14): Exiting normally.

    Question - is it normal for the backup to stop the service due to no connection?

    Error #2 - dnsserver error??

    FATAL: The dnsserver helpers are crashing too rapidly, need help!

    Question - is it dns server error? i had check the dns is running fine. what is the cause of this issue?


Locked