pFsense 2.7.0: pfBlocker upgraded before 2.7.1 upgrade
I have made a mistake. I have upgraded pfBlocker to the last version before the pfsense upgrade from 2.7.0 to 2.7.1 and so I get always an error when I try to upgrade to 2.7.1 or in case of pfblocker rules reload. So, Can I revert the pfblocker package? can I force the 2.7.1 upgrade to fix the libssl 30 missing?
So, Can I revert the pfblocker package?
The best way is to make a backup of your config and install pfsense from scratch and import that config. It is well known, that updating a package when a major upgrade of pfsense is present, is a absolut NoGo - result is always a nonfunctional system.
upgrade from 2.7.0 to 2.7.1 and so I get always an error
What specific error do you get?
See this Thread. I had I think the exact same issue and this solved it:
You made ABSOLUTELY NO MISTAKE!
What kind of mature, enterprise-ready software ever lets you hang yourself!?
This is the result of a glaring not only BUG, but design flaw.
I have 'learned" to be very weary of any package updates, right after the "new release of pfsense.
That is not enterprise-ready at all.
Enterprise-ready means, YOU, NetGate, have and MUST do the thinking and figuring out FOR ME, so it is ALWAYS just a 1 click "solution"!
I know it is not easy, but, it will either get done by you, (or OPNs), somebody else!
The root cause of this issue is fixed in 2.7.1/23.09. Going forward the selected repo branch is not switched when new releases are available. Updates are shown on the dashboard but the user will be required to select the new branch to upgrade.