Vmware + wireless AP



  • I'm loving pfSense so far. I've bee using it for 2 days now.
    Anyways, there is only one issue I've not been able to figure out. Hopefully someone here can help me. Basically, I'm running vmware server on a box and pfsense over vmware. I have a ralink wireless card I want to use as an infrastructure AP broadcast for wireless lan. The problem is after I've setup the card in vmware, set it as a bridge like I do with the ethernet cards, and then go to pfsense … pfSense sees the wifi card like it is any other ethernet card. This is fine if I want to wan the internet in but I want to broadcast ap mode.

    Is there a setting in vmware server I'm overlooking? If not is there a way to 'force' the pfsense Interfaces -> LAN2 page to display wireless information?

    I've even gone as far as to install drivers that support soft ap on the host OS and setting it up that way. This is a bit of a hack because 1) The drivers for my card do not have such features so I'm using unofficial drivers. 2) Not much is supported aka no wpa. 3) The drivers seem to want to take control in ap mode and pre configure everything. This is nice if it worked properly. Unfortunately, it isn't designed to work as an ap bridge. When I enable vmware bridge on the wireless device and then connect via my laptop I can get to the lan 192.168.3.1 (LAN2 is set to static 192.168.3.1) but can not get outside of that aka 192.168.1.1 or google.com. If I enable TCP/IP in the host OS and all of the other things like windows file sharing or whatever it is called then the host OS can be connected via my laptop but that does not necessarily help. Even enabling internet connection sharing between the LAN device that allows the host OS to get online with the wireless card doesn't seem to help.

    Maybe there is something I'm overlooking here. What I really want is pfSense to see my wifi card through vmware as a wifi card not an ethernet card so I can get the options to configure it.

    Can someone please helpe me?  ???
    Thank you.


Log in to reply