PfSense won't work with current DSL connection



  • Hi,

    I've a pfSense box that's not working (can't connect to the internet), I've raised this same issue way back 2008 and it wasn't resolved. The client downgraded their DSL subscription from a plan with /29 public ip to a plan with only one public ip with corresponding username and password to be used when connecting to the internet. I've already replaced the old ip 210.213.xxx.xxx/29 with the new one 124.104.xxx.xxx using the netmask provided by the ISP which is 255.255.255.255 but I can't get pfSense to work, I've already tried setting it to PPPoE and it still doesn't work. When I tried to connect a PC (windows) directly to the modem using the new ip that PC can surf the net, I have no idea why pfSense won't work.

    Any suggestion?

    TIA



  • The DSL modem and pfSense are operating in compatible modes on the pfSense WAN link?

    If you use PPPOE on pfSense then the DSL modem needs to be in some sort of bridged mode. If the modem is acting as a router then you can't have the pfSense WAN link in "PPPOE mode" unless the modem supports that.

    A couple of months ago, when I was running a June 2009 snapshot build of pfSense 1.2.3, I tried to get my ADSL modem to work as a bridge so I could run PPPOE on the pfSense WAN link so pfSense could detect IP address changes on the internet connection. I wasn't able to get PPPOE working, but I confess I didn't try very hard. I don't know whether its a fault in the bridged mode of the particular ADSL modem or a PPPOE bug in that particular build of pfSense or something else. So I reverted to running the ADSL modem as a router and worked out another way to detect the IP address changes on the WAN link.

    I suspect its more common for xDSL modems (especially the cheaper ones) to run as routers, so you are probably less likely to run into problems if you use them as routers.



  • It's now working, the setting that I didn't try before worked this time around. The modem is in bridge mode BTW.



  • @jan:

    It's now working, the setting that I didn't try before worked this time around. The modem is in bridge mode BTW.

    and what might that be?



  • Did anyone ever figure this problem out on a 2wire?

    I have been trying to get my 2wire into bridge mode and working with my pfsense box with no luck. No luck meaning I can not access the internet with any of my machines. Is there some magic trick to getting this done? I am running on a windows 2003 domain with DNS, DHCP, RRAS and Active Directory. I know the pfsense box wants to enable DHCP. I have tried to disable DHCP in the Windows box but with no results. Does bridge work on the 2wire with pfsense?

    On a side note, I can get internet out of the pfsense box if I do not enable the bridged setting on the 2wire but this defeats the purpose as the 2wire is still handling routing and firewalling. I have disabled DHCP on the 2wire as my windows machine handles that.

    Any help you or anyone else might have would be appreciated.

    By the way, I am running dynamic dns with a client application that keeps my ip address and domain name in sync.

    Thanks!


Log in to reply