Slow Internet from LAN



  • I've put a new PFSense firewall in this morning to replace an old Checkpoint firewall and Internet access it a third of the speed it was previously - we have a 1Mb SDSL line and would usually expect to get 100 - 114 kbps downloads when using the old Checkpoint (old NT 4 Checkpoint Fw-1)

    Since putting the PFSense in our maximum downspeed is 30 - 35kbps and I cant for the life of me work out why

    All interfaces have negociated at 100/full as expected

    Any ideas on how I can speed this up greatly appreciated. It's pretty much a default stup of PFsense all I've done is configure the NICs and created some firewall rules to allow traffic in and out.

    Thanks



  • I've noticed just no win the system log I am getting constant errors on the WAN interface

    Oct 16 10:50:20 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:23 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:23 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:26 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:27 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:30 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:30 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:33 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:33 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:37 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:37 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:40 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:40 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:44 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:44 kernel: em2: promiscuous mode disabled
    Oct 16 10:50:47 kernel: em2: promiscuous mode enabled
    Oct 16 10:50:47 kernel: em2: promiscuous mode disabled



  • Another Update:

    I've got rid of the errors I posted earlier by swapping out the Network Card but still can only get around 30/35KBps down.

    Traffic shaping is disabled - I really dont know what could be happeneing here to limit the throughput.

    Any help much appreciated.



  • hmm maybe those errors arnt as gone as I would have hoped..

    Does anyone know how to get rid of these errors?

    Oct 16 11:36:06 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:09 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:10 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:13 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:13 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:16 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:17 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:20 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:20 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:23 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:23 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:26 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:26 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:30 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:30 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:33 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:33 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:37 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:37 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:40 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:40 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:43 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:44 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:47 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:47 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:50 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:51 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:54 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:54 kernel: em1: promiscuous mode disabled
    Oct 16 11:36:57 kernel: em1: promiscuous mode enabled
    Oct 16 11:36:57 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:01 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:01 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:04 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:04 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:08 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:08 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:11 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:11 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:14 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:15 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:18 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:18 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:21 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:22 kernel: em1: promiscuous mode disabled
    Oct 16 11:37:25 kernel: em1: promiscuous mode enabled
    Oct 16 11:37:25 kernel: em1: promiscuous mode disabled



  • those are not actually errors.  something (pftop?) is starting and stopping (I think) - pfsense monitors traffic by sniffing the interface which requires promiscuous mode.



  • Thanks for your reply - Will ignore those messages

    The issue is now resolved - I noticed out of the windows a confused looking BT engineer outside the building while I was considering jumping and ending it all out of frustration. After my colleague approached/beat the truth out of him the mystery was solved.

    It turns out their was an issue on the line that out of some strange coincidence started as I was putting the new firewall. All sorted and fast as lightning now.


Log in to reply