HAProxy - doesn't install



  • Hi guys, I'm trying to install the HAproxy on PFSense 1.2.3-RC3 and after the package installer does a few downloads it gets to:

    Loading package instructions…

    It then doesn't seem to get any further, any thoughts/help on this would be welcome.

    Hass



  • Hi,
    got the same. But I get on bottom of the page this line too:
    Parse error: syntax error, unexpected T_STRING in /usr/local/pkg/haproxy.inc on line 92

    PD


  • Rebel Alliance Developer Netgate

    Looks like there was a missing ;

    Should be fixed now, or as soon as the package repo picks up the change.



  • Thanks Jimp, yes all sorted, I just need to learn how to use the package!



  • Thanks Jimp.

    PD



  • Test the installation,
    run positiv:
    Executing custom_php_install_command()…done.
    Writing configuration... done.
    Starting service.

    Installation completed.  Please check to make sure that the package is configured from the respective menu then start the package.

    But get on the bottom of the page:
    Warning: fopen() expects at least 2 parameters, 1 given in /usr/local/pkg/haproxy.inc on line 87 Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/pkg/haproxy.inc on line 88 Warning: fclose(): supplied argument is not a valid stream resource in /usr/local/pkg/haproxy.inc on line 89

    PD



  • Should be fixed.  Sorry for the breakage.



  • No problem,
    better as no one get back with a failure to you  ;D

    PD


Log in to reply