Squid + squidguard não funciona!



  • Galera,

    estou com uma imensa dificuldade em fazer com que o SQUID + Squidguard funcione.
    usuário de primeira viajem do PFSENSE que por sinal é muito bom. Consegui instalar e configurar e alguns serviços estou funcionando perfeitamente.

    Rede internet: 192.168.0.100 - 200 / 24 (DHCP server habilitado)
    Rede externa: 192.168.1.2 / 24 - modo ip estatico (modem com PPPOE) (está dessa forma pois quando deixei o PFSENSE em PPPOE, até autenticava mas nao navegava, provavelmente um problema de DNS ou NAT que nao sei como configurar nele.

    Bom baixei os pacotes instalei e inclusive baixei uma lista de bloqueios de um site, onde ja vem com alguns bloqueios por padrao. ativei alguns mas nao funciona.

    Objetivo aqui na rede é bloquear ORKUT, MSN, youtube e radios on line.

    Rodei o forum inteiro inclusive tenho alguns videos aqui mas realmente nao funciona.

    Galera poder dar uma força e explicar direitinho como devo proceder nas configurações ficaria grato.



  • Caro,

    Você disse que não bloqueia nenhum site, mas se baixou a lista da internet do squidguard, verifique se há o endereço orkut.com, se não houver o bloqueio não irá se efetivar mesmo.

    Verifique no serviço Proxy Filter se o mesmo está Parado, se estiver o bloqueio também não irá funcionar.

    Verifique no  "Diagnostic" -> "edit file" o arquivo squid.conf, não me lembro se é /usr/etc/squid/squid/conf, mas pode verificar através do comando "find / -name "squid.conf", se há a linha redirect program.

    Se possível poste o nome da lista que você baixou, caso queira, selecione a opção "Destinations" e insira a URL orkut.com e depois crie a ACL para bloqueio da página e teste.



  • Caros,

    Estou com o mesmo problema. Estou usando a URL http://www.shallalist.de/Downloads/shallalist.tar.gz como blacklist. Experimentei páginas como o Orkut, facebook e outros, que estão inclusos na lista, mas não tenho sucesso.

    Apenas salientando, segui o tutorial disponível em http://files.pfsense.org/tutorials/squidguard/squidGuardQuick.htm para configurar o SquidGuard e aparentemente tudo foi configurado como esperado. Não sei se tenho que fazer mais alguma configuração no próprio pacote do Squid.  :-\

    No arquivo mencionado (/usr/local/etc/squid/squid.conf) tenho:

    # Do not edit manually !
    http_port 10.0.0.1:3128
    icp_port 0
    
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_directory /usr/local/etc/squid/errors/English
    icon_directory /usr/local/etc/squid/icons
    visible_hostname localhost
    cache_mgr admin@localhost
    access_log /dev/null
    cache_log /var/squid/log/cache.log
    cache_store_log none
    shutdown_lifetime 3 seconds
    uri_whitespace strip
    
    cache_mem 8 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir aufs /var/squid/cache 100 16 256
    minimum_object_size 0 KB
    maximum_object_size 10 KB
    offline_mode off
    
    # No redirector configured
    
    # Setup some default acls
    acl all src 0.0.0.0/0.0.0.0
    acl localhost src 127.0.0.1/255.255.255.255
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901  3128 1025-65535
    acl sslports port 443 563 
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    acl dynamic urlpath_regex cgi-bin \?
    cache deny dynamic
    http_access allow manager localhost
    
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    
    # Always allow localhost connections
    http_access allow localhost
    
    request_body_max_size 0 KB
    reply_body_max_size 0 allow all
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_initial_bucket_level 100
    delay_access 1 allow all
    
    # Custom options
    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
    redirector_bypass on
    redirect_children 3
    # Default block all to be sure
    http_access deny all
    
    

    Se alguém puder dar uma luz, estamos aí para trocar infos.

    Valeu!



  • –> Verifique no serviço Proxy Filter se o mesmo está Parado, se estiver o bloqueio também não irá funcionar.

    - Serviço esta funcionando nos status.

    **–> Verifique no serviço Proxy Filter se o mesmo está Parado, se estiver o bloqueio também não irá funcionar.

    Verifique no  "Diagnostic" -> "edit file" o arquivo squid.conf, não me lembro se é /usr/etc/squid/squid/conf, mas pode verificar através do comando "find / -name "squid.conf", se há a linha redirect program.**

    - Verifiquei e existe sim: [ redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf ]

    O nome da lista que baixei é esta [http://www.shallalist.de/Downloads/shallalist.tar.gz]

    Bom a nivel de teste deixei somente o SQUID server rodando e desinstalei o SQUID Guard. E funcionou perfeitamente porem consigo efetuar apenas alguns bloqueios simples na guia "ACCESS CONTROL / BLACKLIST".

    As vezes pode ser uma dificuldade de como bloquear no SQUIDGUARD. Talves se alguem podesse mostrar o procedimento de criar uma ACL bloqueando uma determinada lista de SITES seria legal pois pelo tanto que rodei o forum é a dificuldade da grande maioria que inicia com esse PF que pelo visto é muito bom.

    Agradeço a atenção de todos.



  • faz um backup das configurações e reinstala o pfsense com a versão mais atual, pode ser que resolva.



  • Fiz o backup, reinstalei o pfSense, restaurei o backup e agora está funcionando 100%. Balanceamento + Firewall + SquidGuard.

    Obrigado e grande abraço a todos!!!



  • GAlera desculpe a "ignorancia" minha mas…

    o PF que tenho aqui instalado foi pelo LIVECD que está em iso a ponto de gravar e instalar.

    no caso da versão 1.2.3 está em img basta gravar e dar o bot normalmente ou tem outro procedimento.

    vlw a todos


Log in to reply