Squid Package subnet noauth issue



  • I don't know if this is a bug that has been addressed (I'm running 1.2.3-RC1) with the squid package.

    Under Services -> Proxy Server -> Auth Settings -> Subnets that don't need authentication

    If I list two subnets out as:

    x.x.x.x/28
    y.y.y.y/30

    Behavior that happens when doing above settings are x.x.x.x/28 can get through with out authentication, y.y.y.y/30 still requires auth.  I reversed them with the same symptoms, y.y.y.y/30 could get through, x.x.x.x/28 could not.  I looked at the squid.conf file and found:

    acl noauth src x.x.x.x/28^M y.y.y.y/30

    Yes, it puts the carriage return ^M in there.  Also I believe the syntax for multiple subnets being assigned to an acl (correct me if I'm wrong?) is:

    acl noauth src x.x.x.x/28
    acl noauth src y.y.y.y/30

    Btw, not a priority issue by any means, was able to work around it by doing such:

    Put this in the extra config options:
    acl noauth src x.x.x.x/28; acl noauth src y.y.y.y/30;

    Put localhost in Auth settings option:
    127.0.0.1/32

    This at least is working as a temporary workaround.

    Chris


Log in to reply