Squid update failed



  • After updating squid from v2.6 to v2.7.7, I've got this error
    Oct 20 18:10:41 squid[8452]: Exiting due to repeated, frequent failures
    Oct 20 18:10:41 squid[8452]: Squid Parent: child process 11318 exited due to signal 6
    Oct 20 18:10:41 kernel: pid 11318 (squid), uid 62: exited on signal 6
    Oct 20 18:10:41 squid[11318]: The basicauthenticator helpers are crashing too rapidly, need help!
    Oct 20 18:10:41 squid[8452]: Squid Parent: child process 11318 started
    Oct 20 18:10:39 check_reload_status: reloading filter



  • backup your squid.conf, remove the package (at that point I'd be tempted to bounce the firewall) and then cleanly install the new package. Edit the new squid.conf file using the old one as a guide, do not just paste the old one back in as some things have changed.



  • I tried to uninstall squidguard and squid.
    I reinstall both packages without change anything in conf but same error

    Try again and again. but no chance, always same pb
    Oct 20 22:34:34 squid[36218]: Squid Parent: child process 37188 exited due to signal 6
    Oct 20 22:34:34 kernel: pid 37188 (squid), uid 62: exited on signal 6
    Oct 20 22:34:34 squid[37188]: The basicauthenticator helpers are crashing too rapidly, need help!
    Oct 20 22:34:34 squid[36218]: Squid Parent: child process 37188 started
    Oct 20 22:34:31 check_reload_status: reloading filter

    All works good if I set no authentication on squid.
    But for ldap auth. the 'basicauthenticator' crashed


  • Rebel Alliance Developer Netgate

    You might need to stop squid, clear out the cache dir, run squid -z again, then reinstall.

    I recall seeing the "crashing too rapidly" error before and I seem to recall it was due to something in the cahce directory, but that's just a vague memory at this point.



  • I tried to start with squid -z and now, I lost connection to the WebGUI of pfsense :(
    Proxy works with no auth but if I put auth to ldap crash again.

    My problem now is to take back my webgui access. Is there a command to restart the WebGUI ?



  • That sounds like squid is running in transparent mode on port 80 and blocking the web console.

    You can restart the web gui from the console menu either locally or by using an ssh client to connect and selecting option 11



  • Ok, I keep back the WebGui interface with option 11
    But still have problem with ldap auth :(
    Can't manage to solve it.


Log in to reply