Imspector stops logging



  • using 1.2.3-RC3 with the default package install of Imspector 0.8-9 and nothing else. It will log for a while then stop. Once it stops, I have to deinstall the package, reboot, reinstall and will repeat the problem. I've tried the default imspector.conf that get's used and tried to use the imspector.conf.sample to no avail.

    Do I need another package to make this work reliably?



  • I've also tried to follow what helped this person, http://forum.pfsense.org/index.php/topic,18218.msg93864.html#msg93864

    but it seems that there is one more place that has /var/imspector/ hard-coded for the logging, because any change using the gui results in the log location being changed.



  • @five0.4tluv:

    I've also tried to follow what helped this person, http://forum.pfsense.org/index.php/topic,18218.msg93864.html#msg93864

    but it seems that there is one more place that has /var/imspector/ hard-coded for the logging, because any change using the gui results in the log location being changed.

    does anyone solve this problem?
    my imspector starts to no loging now ..  >:(



  • Does this pertain to only some networks or all? I see fresh logs from IRC in my imspector and I'm using 1.2.3-RC3 and latest imspector 0.8-9.

    I think there must be various kinds of interactions between some mixes of packages that causes some problems. I've also run into thes kinds of problems with imspector earlier with 1.2.2 and now I have problems with captive portal and obviously noone else does since I get no replies to those questions that solves it for me.

    Perhaps it's needed to post full list of installed and running/not running packages in addition to describing the problem at hand, to pin some of these issues down.



  • Dear All

    I sovled this problem by myself. you can check this.

    at first . I check in menu, status->system logs.
    I found this messages:

    Oct 24 00:25:28 imspector: dlopen(): Shared object "libmysqlclient.so.15" not found, required by "mysqlloggingplugin.so"
    Oct 24 00:25:28 imspector: dlopen(): Shared object "libmysqlclient.so.15" not found, required by "mysqlloggingplugin.so"

    then I go to /usr/local/lib/imspector , to move "mysqlloggingplugin.so" to another place. (remove this file in that directory)

    and restart the service, then IMspector can log in file now in my case.  ::)



  • I have another pfsense install that is the same v. 1.2.3b3 with only imspector and ntop installed and it is logging with no changes to any configs. but this install will not.

    I'm still trying to figure out how IM traffic is suppose to go to port 16667 specified during debug

    /usr/local/sbin/imspector -d -c /usr/local/etc/imspector/imspector.conf
    imspector: Protocol Plugin name: ICQ-AIM IMSpector protocol plugin
    imspector: Protocol Plugin name: MSN IMSpector protocol plugin
    imspector: Protocol Plugin name: Yahoo IMSpector protocol plugin
    imspector: Non-HTTP port listening on 0.0.0.0:16667
    imspector: Logging Plugin name: Debug IMSpector logging plugin
    imspector: Logging Plugin name: File IMSpector logging plugin

    seems like some PF rules need to be in place which aren't.



  • I use 1.2.2 and IMSPECTOR version 0.8-9.. Works like a charm.


Log in to reply