Squid 2.7.7 unrecognized :



  • I use pfsense 1.2.2 dev., i new installation squid 2.7.7 but following message and dont working ;

    squid

    2009/10/21 23:00:28| parseConfigFile: squid.conf:57 unrecognized: 'delay_pools'
    2009/10/21 23:00:28| parseConfigFile: squid.conf:58 unrecognized: 'delay_class'
    2009/10/21 23:00:28| parseConfigFile: squid.conf:59 unrecognized: 'delay_parameters'
    2009/10/21 23:00:28| parseConfigFile: squid.conf:60 unrecognized: 'delay_initial_bucket_level'
    2009/10/21 23:00:28| parseConfigFile: squid.conf:61 unrecognized: 'delay_access'
    2009/10/21 23:00:28| Squid is already running!  Process ID 18651

    Where is error , problem is squid or my system ?


  • Rebel Alliance Developer Netgate

    Do you also use squidguard?

    You need to do something like this:

    • Update squid

    • Reinstall squidguard

    • Go to Services > Proxy and click Save (you do not need to make any changes)

    • Go to Services > Proxy Filter and click Save (you do not need to make any changes)

    • Click Apply on squidguard config

    That should make sure that everything is installed and (re)configured properly.

    Even if you don't have squidguard, it's still a good idea to first go back and click Save on the squid config page to make sure it has properly written out an up-to-date config file.



  • Hello, i m using Pfsense 1.2.3-RC1 , reinstall Squid, Squidguard , save , apply , reinstall Lihghtsquid but still got the same message , my mistake not to backup squid config dir :-[



  • I had to reinstall SquidGuard twice because I've encountered errors during the 1st try and kinda broke the SquidGuard GUI that's why I reinstalled it again, everything is working fine again, also re-upload the blacklist URL if you're using shallalist et. al.



  • @jimp:

    Do you also use squidguard?

    You need to do something like this:

    • Update squid

    • Reinstall squidguard

    • Go to Services > Proxy and click Save (you do not need to make any changes)

    • Go to Services > Proxy Filter and click Save (you do not need to make any changes)

    • Click Apply on squidguard config

    That should make sure that everything is installed and (re)configured properly.

    Even if you don't have squidguard, it's still a good idea to first go back and click Save on the squid config page to make sure it has properly written out an up-to-date config file.

    Installed pfsense 1.2.2 and full update , only packages squid install.Only packages squid.
    Go to Services > Proxy and click Save and Go Shell Promt > # /usr/local/sbin/squid
    2009/10/22 13:44:03| parseConfigFile: squid.conf:57 unrecognized: 'delay_pools'
    2009/10/22 13:44:03| parseConfigFile: squid.conf:58 unrecognized: 'delay_class'
    2009/10/22 13:44:03| parseConfigFile: squid.conf:59 unrecognized: 'delay_parameters'
    2009/10/22 13:44:03| parseConfigFile: squid.conf:60 unrecognized: 'delay_initial_bucket_level'
    2009/10/22 13:44:03| parseConfigFile: squid.conf:61 unrecognized: 'delay_access'
    2009/10/22 13:44:03| Squid is already running!  Process ID 7328



  • This is squid port dont know delay pools config opions.



  • same issue here too …



  • got the same problem, do you live?



  • Is it possible to take back to v2.6 ?
    With 2.7 I've got the same error messages + ldap auth that doesn't work anymore



  • Hi,

    Thanks



  • its mean, this squid package build with no option –enable-delay-pool

    try squid -v

    for fix, delete and install new squid package with command console

    
    pkg_delete squid-2.7.7
    pkg_add -rv http://shakau.googlepages.com/full-squid-2.7.7.tbz
    rehash
    squid -v
    
    

    good luck



  • I did compile it with delay pool, not sure why it's doing that. I'll recompile it this weekend.

    I would encourage everyone not to install binaries from random links that people post, if they aren't coming from official freebsd.org or pfsense.org servers, you have no idea what that package might actually contain.

    A quicker fix if it's not working for you (it's working fine for others) is to run:

    pkg_delete squid-2.7.7
    pkg_add -rv http://files.pfsense.org/packages/7/All/squid-2.6.21.tbz
    
    

    Then go into the GUI and restart Squid. You do not have to uninstall the package, just do the above.



  • @cmb:

    pkg_delete squid-2.7.7
    pkg_add -rv http://files.pfsense.org/packages/7/All/squid-2.6.21.tbz
    
    

    Then go into the GUI and restart Squid. You do not have to uninstall the package, just do the above.

    GREAT !!! Thanks for all. My squid works like before. No pb with the ldap auth.
    I'll check later to see the accent character problems still exist or not.



  • CMB said : I'll recompile it this weekend.
    Please, inform us when this be done.

    squid -v
    Squid Cache: Version 2.7.STABLE7

    --disable-epoll
    ...

    2009/11/02 10:59:49| parseConfigFile: squid.conf:71 unrecognized: 'delay_pools'
    2009/11/02 10:59:49| parseConfigFile: squid.conf:72 unrecognized: 'delay_class'
    2009/11/02 10:59:49| parseConfigFile: squid.conf:73 unrecognized: 'delay_parameters'
    2009/11/02 10:59:49| parseConfigFile: squid.conf:74 unrecognized: 'delay_initial_bucket_level'
    2009/11/02 10:59:49| parseConfigFile: squid.conf:75 unrecognized: 'delay_access'


Log in to reply