NVidia card not recognized as gigabit



  • Hi All-

    I just got finished installing pfSense 1.2.3 rc3 on to my shiny new acer AspireRevo 1600.

    It has a built-in 10/100/1000 network card, which shows up in the dmesg as:

    nfe0: <nvidia nforce="" mcp79="" networking="" adapter="">port 0xd080-0xd087 mem 0xfae7d000-0xfae7dfff,0xfae7e800-0xfae7e8ff,0xfae7e400-0xfae7e40f irq 21 at device 10.0 on pci0
    miibus1: <mii bus="">on nfe0

    ifconfig is showing it as 100mb:

    nfe0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=10b <rxcsum,txcsum,vlan_mtu,tso4>ether 00:22:68:68:ec:7c
    inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    inet6 fe80::222:68ff:fe68:ec7c%nfe0 prefixlen 64 scopeid 0x2
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active

    Any idea how I can force it to be recognized as gigabit?

    The specs clearly say that it should be gigabit, and it was recognized as such when I booted to XP (before I nuked that ;))

    Here is what shows from pciconf -lv :

    nfe0@pci0:0:10:0: class=0x020000 card=0x02221025 chip=0x0ab010de rev=0xb1 hdr=0x00
       class      = network
       subclass   = ethernet

    Many thanks,

    -jamie</full-duplex></rxcsum,txcsum,vlan_mtu,tso4></up,broadcast,running,simplex,multicast></mii></nvidia>



  • I edited the config.xml, and set it to 1000 Mb:

    <lan><if>nfe0</if>
                            <ipaddr>192.168.1.1</ipaddr>
                            <subnet>24</subnet>
                            <media><mediaopt><bandwidth>1000</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan>

    Is that the right way to do this?



  • ifconfig is showing you the current link speed, not the speed it is capable of.  I assume you have the card attached to a 100Mbps switch, hence it showing a 100Mbps link.



  • No, it is attached to a gigabit switch.

    after reloading with the above config, it now shows:

    nfe0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=10b <rxcsum,txcsum,vlan_mtu,tso4>ether 00:22:68:68:ec:7c
    inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    inet6 fe80::222:68ff:fe68:ec7c%nfe0 prefixlen 64 scopeid 0x2
    media: Ethernet autoselect (1000baseTX <full-duplex>)
    status: active</full-duplex></rxcsum,txcsum,vlan_mtu,tso4></up,broadcast,running,simplex,multicast>


Log in to reply