Webgui gone after reboot



  • Hi,

    I'm trying to use the build of 23-09-2009.
    Everything is fine during install and fist boot. Then i log into the webinterface, set up the lagg0, dump some vlans over it (which by the way show as down.) set up dhcp and dns. Reboot and then the Webgui says faied to start.
    The routing works fine.

    So i think i check the log files but when i hit "less /var/log/lighttpd.log" it says its an binary file.

    Does anyone know whats going on here?

    I did try the build of 25-10-2009 but then i get an "panic: page fault" when setting up the lagg0 with the vlans.

    Thanks, and greets, Marcus



  • I'm seeing something similar using nanobsd Freebsd 8
    pfSense-2.0-ALPHA-ALPHA-512mb-20091019-1122-nanobsd.img.gz

    After I use the console to change the webgui from https to http and restart, I see this error in the system log.

    Oct 26 15:13:22 bv-firewall php: : The command '/usr/local/sbin/lighttpd -f /var/etc/lighty-webConfigurator.conf' returned exit 
    code '255', the output was 'Undefined config variable: var.Array 2009-10-26 15:13:22: (configfile.c.867) source: /var/etc/lighty-
    webConfigurator.conf line: 134 pos: 16 parser failed somehow near here: (EOL)'
    
    

    When I look at /var/etc/lighty-webConfiguration.conf is see that the port is set to = Array, looks like the wrong value is getting substituted into that config file.

    ## bind to port (default: 80)
    server.port                = Array
    
    

    When I look at a known good config backup the webgui section looks like this.

    		 <webgui><protocol>https</protocol>
    
    			<ssl-certref>Blah</ssl-certref></webgui> 
    

    When I look at the config file on the firewall I see this.

     <webgui><protocol>http</protocol>
    
                            <ssl-certref>Blah</ssl-certref></webgui> 
    
    

    Does the fact that there is a return between the port tags cause this problem?  Does /etc/inc/system.inc interpret the extra enter as an array or a non standard port?

            /* non-standard port? */
            if (isset($config['system']['webgui']['port']) && $config['system']['webgui']['port'] <> "")
                    $portarg = "{$config['system']['webgui']['port']}";
    
    

    Is there possibly a bug that adds an extra return to the webgui port setting when resetting the webgui to http via the console?
    Thanks
    Josh



  • Hi,

    Now you showed me where to look, i see the same thing.
    When fixing the port and creating a pid file for lighttpd and starting it with "lighttpd -f /var/etc/lighty-webConfigurator.conf" it works.
    But when you hit the reset webconfigurator option in the console menu it trys to run on port "array"

    Grts, Marcus



  • After I edit the /var/etc/lighty-webConfigurator.conf and set the port to 80, and start lighttpd manually, the web gui works.

    When I go into System -> advanced, under webconfigurator the TCP port field contains this error.

    "Warning: htmlspecialchars() expects parameter 1 to be string, array given in /usr/local/www/system_advanced_admin.php on line 264"

    When I enter port 80 and save, the config file now shows.

    <port>80</port>
    

    If I enter nothing in the port field and save the config file shows

     <webgui><protocol>http</protocol>
                      <port>…</port></webgui> 
    

    I'm assuming that is the new correct way to store an empty tag.

    Should there be a check in system.inc that looks to see if the port is set to an array and to sanitize it if it is.
    Thanks
    Josh



  • So i probably broke the webserver my self when changing some configuration in the advanced tab, i then saved the error in the port field.
    Still there is room for improvement on pfsense's side ;-)

    Now the other thing that is bothering me is the vlans showing as down, and thus not generating any graphs on the dashboard (they do in the status->traffic graphs).

    Could anybody help me out on that one?

    Grts, Marcus



  • I believe there are already threads open about the vlan showing as down issue, you should probably post to those as that is a new topic.
    Josh


Log in to reply