PCMCIA card not detected…



  • Hi All,

    I new here as I am trying to install pfSense for the first time.
    Hardware older Toshiba Laptop P4M 1.86GHz with 1GB RAM.
    pfSense version 1.2.3-RC3 and I have tried 2.0 Alpha.
    NICs = Build-in LAN card and PCMCIA D-Link DFE-690 card. Under supported HW DFE-690 is listed as supported.
    Buld-in LAN card detected.
    PCMCIA D-Link DFE-690 card is not detected. The D-Link is listed in HW Supported List as supported.
    Under Win XP (same laptop) the DFE-Card works.
    The WiFi card is detected and so the Firewire and USBs.

    Attached "dmesg" dump if can help.

    Ideas?

    Thanks - Steen
    [pfSense dmesg file 28102009.txt](/public/imported_attachments/1/pfSense dmesg file 28102009.txt)



  • In the startup output you posted there is no evidence of any device plugged into the cardbus bridge.
    Are you sure it was there on startup?

    Secondly, an unusual aspect of the startup output you reported was that only one cardbus bridge was reported. That MIGHT be correct but every other cardbus bridge I've come across is part of a package with two bridges. Your startup shows only one bridge. Is it possible part of the startup report is missing?

    Could you post the output of the shell command:

    # pciconf
    

    which should show all the PCI devices and cardbus devices on the system.

    In this section of your dmesg output:

    cbb0: <ti6411 pci-cardbus="" bridge="">at device 6.0 on pci6
    pcib4: cbb0 requested memory range 0xb0000000-0xb7ffffff: good
    cbb0: Lazy allocation of 0x1000 bytes rid 0x10 type 3 at 0xb0001000
    cardbus0: <cardbus bus="">on cbb0
    pccard0: <16-bit PCCard bus> on cbb0
    pcib4: matched entry for 6.6.INTA (src \\SB.PCI0.LPCB.LNKC:0)
    pcib4: slot 6 INTA routed to irq 11 via \\SB.PCI0.LPCB.LNKC
    cbb0: [MPSAFE]
    cbb0: [ITHREAD]
    cbb0: PCI Configuration space:
      0x00: 0x8031104c 0x02100007 0x06070000 0x00824000
      0x10: 0xb0001000 0x020000a0 0x40080706 0xfffff000
      0x20: 0x00000000 0xfffff000 0x00000000 0xfffffffc
      0x30: 0x00000000 0xfffffffc 0x00000000 0x0740010b
      0x40: 0xff101179 0x00000001 0x00000000 0x00000000
      0x50: 0x00000000 0x00000000 0x00000000 0x00000000
      0x60: 0x00000000 0x00000000 0x00000000 0x00000000
      0x70: 0x00000000 0x00000000 0x00000000 0x00000000
      0x80: 0x0840b060 0x00000000 0x000f0082 0x01aa1b22
      0x90: 0x606600c0 0x00000000 0x00000000 0x00000000
      0xa0: 0xfe120001 0x00c00000 0x00000000 0x00000000
      0xb0: 0x00000000 0x00000000 0x00000000 0x00000000
      0xc0: 0x00000000 0x00000000 0x00000000 0x00000000
      0xd0: 0x00000000 0x00000000 0x00000000 0x00000000
      0xe0: 0x00000000 0x00000000 0x00000000 0x00000000
      0xf0: 0x00000000 0x00000000 0x00000000 0x00000000
    fwohci0: vendor=104c, dev=8032
    fwohci0: vendor=104c, dev=8032
    fwohci0: <1394 Open Host Controller Interface> mem 0xb0000000-0xb00007ff,0xb0004000-0xb0007fff irq 9 at device 6.2 on pci6
    fwohci0: Reserved 0x800 bytes for rid 0x10 type 3 at 0xb0000000
    fwohci0: [MPSAFE]
    fwohci0: [FILTER]
    fwohci0: OHCI version 1.10 (ROM=0)</cardbus></ti6411>

    the first line of the fwohci is repeated (unusual) and there is no cbb1 at device 6.1 on pci6. I don't know for certain there should be a cbb1 because I'm not familiar with this particular cardbus bridge. But every other cardbus bridge I've come across has a second bridge at function 1 (that is, there would be a cbb1 at device 6.1 on pci6).

    Given that Windows XP can find the cardbus NIC I'm suspecting that either there is no device driver recognising the cardbus NIC OR the driver that does recognise it reports an error.



  • Hi wallabybob,

    You are right, there seams to be no device, but card is plugged into the bridge. Initial I had XP on the hard drive and loaded pfSense via CD live, so I could check the card worked.

    The command "# pciconf" did not result in any output.
    While the command "# pciconf -l" did. Output attached, not knowing this is what you look for.

    I believe for some reason the cardbus driver is not there, or something like that

    Thanks - Steen

    [seh2000 pciconf -l.txt](/public/imported_attachments/1/seh2000 pciconf -l.txt)



  • FreeBSD is not seeing the device plugged into the cardbus slot. Its not even seeing to the point of recognising there is some device plugged in.

    Its been my experience that the BIOS doesn't always initialise cardbus bridges in such a way that FreeBSD can see downstream devices. It might be worth checking with Toshiba support to see if there is a more recent BIOS that might help.

    An alternative to the cardbus NIC would be a USB NIC. There is at least one thread in the forums on USB NICs ad support in FreeBSD/pfSense.



  • Yes, I see…
    I got the latest BIOS earlier today, but no difference.
    The Laptop is a few years old, so not much support to get from Toshiba.
    I actually got a USB NIC its for my son's Wii.
    Just before I read your suggestion I tried it out and believe it or not this USB NIC is detected.

    However, no traffic is flowing through pfSense, but I assume this is for other reason.
    I'll guess I have to accept that I cannot get my PCMCIA D-Link DFE-690 card I just bought for this solution.

    Thanks - Steen



  • @seh2000:

    I'll guess I have to accept that I cannot get my PCMCIA D-Link DFE-690 card I just bought for this solution.

    That might depend on how much time you are prepared to put into researching the problem and your level of expertise. I suspect for a lot of people it would be more worthwhile to spend the salary of a couple of hours work to buy some new equipment over spending hours and hours of time trying to make something they already have work.



  • Yep you have the reason…
    As the USB NIC is working and pfSense is now up and running, I can do my testing on the old laptop.
    The later order HW needed to build a new "PC"...
    Thanks for your inputs!
    BR// Steen


Log in to reply