VPN PPTP : Connexion impossible ensuite GROSSE Lenteur sur la connexion VPN



  • Bonjour,

    Je viens de configurer un VPN PPTP d'après le HOW-TO suivant http://doc.pfsense.org/index.php/VPN_Capability_PPTP

    Voilà se que ça donne : voir image en PJ

    La config VPN sur le serveur FW_PF :

    • Adresse du serveur : IP_WAN_PF
    • Remote address range : 192.168.1.80 /28 (plage de mon LAN non utilisé)
    • Require 128-bit encryption est coché

    La connexion du client fonctionne, je peux même aller sur le NET (je récupère l'IP_WAN_PF sur le site monip.com)
    Mon ip pour le VPN est 192.168.1.81 (ip fixe configurer sur FW_PF pour l'utilisateur connecté)

    Par contre impossible de communiquer avec le LAN

    La règles firewall pour PPTP est la sivante :

      • *    *    LAN net    *    *       | PASS VPN –> LAN

    Sur le WAN j'autorise le protocole GRE(*) et TCP(1723) sur IP_WAN

    Je n'ai rien configurer sur le LAN, pas de NAT ...

    ai je oublié quelque chose ?

    Pourriez vous m'aider SVP?

    Merci

    ![FORUM VPN.jpg_thumb](/public/imported_attachments/1/FORUM VPN.jpg_thumb)
    ![FORUM VPN.jpg](/public/imported_attachments/1/FORUM VPN.jpg)



  • Petit up please



  • Dans la doc, je lis

    Pfsense automagically creates the following rules to allow GRE and TCP/1723 to pass inbound to your PPTP termination point

    En français cela veut dire qu'il n'y a pas à faire de règles !

    Compte tenu de l'exceptionnelle longueur de la doc, il ne me semble pas impossible d'y arriver. Mais …

    J'ai beaucoup de mal à voir l'intérêt d'utiliser le bien vieux protocole PPTP alors qu'OpenVPN offre et le roadwarrior et le net-to-net.



  • Merci et c'est exactement ce que j'ai fait

    Je crée un nouveau POST parce que là aussi la connexion fonctionne, mais je ne ping rien du tout



  • Ne pas pinguer ne renseigne pas beaucoup.

    En effet, un ping c'est un paquet icmp (echo request) dans un sens, et un paquet icmp (echo reply) dans le sens retour.

    Il serait bon de regarder

    • sur la machine destination, ce qui arrive et s'il part quelque chose,
    • sur pfsense, le paquet allant vers la machine destination et le paquet retour.

    Y a-t-il besoin de créer des règles vers le réseau d'adresses ip fournies par le serveur PPTP ?
    Je l'ignore mais cela est possible

    (et je ne vais pas chercher parce que je pense vraiment meilleur et plus sûr=sécurité de faire de l'OpenVPN.)



  • Avez vous essayez de configurer un subnet autre qu'un morceau du subnet LAN pour vos clients PPTP  (pour que cela fonctionne il faut que votre firewall soit la route par defaut de vos serveurs ou que vous ajoutiez une route vers ce subnet).
    Faites l'essai pour voir ce que cela donne.



  • Bonjour et Merci pour votre aide.

    Je suis enfin parvenu à me connecter en VPN PPTP (J'ai bien l'intention de passer en OPENVPN mais je tiens à réussir le pptp)

    Je ne suis pas certain de la résolution mais voilà : La règle la plus basse de mon firewall sur le LAN et le WAN était  un REJECT ALL.
    De plus, l'option ajouter automatiquement les règles pour les VPN était coché.
    J'ai donc décocher cette option, configurer les règle moi même et rien changer au reste.

    Sinon, j'ai un autre souci :
    Le VPN se connecte sur une ligne à 8Mega SDSL ORANGE (Un test du débit monte entre 6 et 7Mega).

    Je tente une connexion RDP  (commande "mstsc" 15Ko à peu près) avec un paramétrage demandant le moins de débit possible
    RÉSULTA : J'ai un affichage minitel bande par bande, trop lent pour une 8 MEGA)

    Un autre test, je récupéré un fichier sur un filer
    RÉSULTA :débit maxi 25 Ko/sec (Débit donnée par super copieur)

    Je sais cela va en énerver plus d'un mais j'ai essayé de changer mon MTU (1500 –>1400) je suis quand même monté à 30 Ko Maxi sur le transfert de fichier. Pour vous rassurer j'ai supprimer l'option car 5Ko de plus ne me suffisent pas)

    Qu'en pensez vous ?...?

    Merci



  • En effet c'est bas (pour rappel en SDSL 8M (ATM) on a 6,4M IP). Le problème provient surement de la ligne par laquelle le client était connecté  non ? Vous ne précisez qu'une seule des lignes Internet, vous avez une SDSL d'un côté et de l'autre ?



  • Alors, coté client VPN, j'ai une ADSL de plus de 5Mega (peu être 18Mega) chez Neuf SFR.

    Je viens de tester chez moi, j'ai une ligne Numericable (Sur un mac lol, Download:12Mega et Upload: entre 1,5 et 2Mega) et j'ai le même souci…

    Pour info mon serveur est un Dell R200 en rack Dual Core Intel Xeon, 3.16GHz avec 4 Go de RAM (un peu surdimensionner je sais) et pour Pfsense je suis sur 1.2.3-RC (j'aurais peu être pas dû, non ?)...

    Merci



  • Quelqu'un a déjà eu des problème de lenteur sur le VPN??

    Merci



  • Bonjour,
    Je viens aux nouvelles.

    J'ai installé un nouveau FW Pfsense en 1.2.2, depuis je n'ai plus ce problème de lenteur pour le VPN mais pas seulement.
    J'avais NATTER le port FTP de mon IP_WAN vers un serveur dans mon LAN : j'aivais exactement le même souci de lenteur. mais après être passé sur la 1.2.2, plus de problème.

    Pour info j'etait en 1.2.3RC
    Qu'en pensez vous ?
    Quelqu'un a t-il rencontré le même souci ???
    Merci



  • est-ce des cartes Intel PRO 100 ?



  • La carte réseau est une  Intel® PRO/1000 ET server

    J'ai fais une autre modification sur le serveur avant de le passer en 1.2.2 :
    -J'ai voulu ajouter une carte réseau en plus pour de future changement, et pour cela j'ai dû retirer le contrôleur RAID. Sa pourrais être ça ??



  • Ok, aviez vous testé en désactivant l'option "hardware checksum  offloading". En 1.2.3 (FreeBSD 7.2, il y a une régression sur ce point dans le driver FXP donc cartes Intel), votre problème de lenteur peut donc venir de là.



  • J'ai décoché le paramètre "Disable Hardware Checksum Offloading"
    Et rien n'as changé.
    J'ai l'intention d'acheter une carte réseau supplémentaire. Que me conseillez vous comme carte réseau 4 ports pour mon Firewall ?





  • J'ai déjà cette carte en ma possession sur un firewall en 1.2.2
    Je vais tenté de le mettre à jour…
    Merci à tous...
    To Be continued... ;)


Log in to reply