Disabling autosense on NIC



  • I am getting no carrier on the WAN, right after plugging in WAN it loses connection. I have tried to change config.xml like;

    <media>100 base TX
    <mediaopt>full duplex</mediaopt>

    Looking at ifconfig its says autoselect none</media>



  • Try a crossover cable.



  • @sullrich:

    Try a crossover cable.

    ;D



  • @Willem:

    I am getting no carrier on the WAN, right after plugging in WAN it loses connection. I have tried to change config.xml like;

    <media>100 base TX
    <mediaopt>full duplex</mediaopt>

    Looking at ifconfig its says autoselect none</media>

    I doubt that these options are correct. Did you run ifconfig -m to see the valid options for your NIC?
    For example, a sis interface on a wrap shows these options:

    
    sis0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    	options=8 <vlan_mtu>capabilities=48 <vlan_mtu,polling>inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    	inet6 fe80::20d:b9ff:fe01:2c8%sis0 prefixlen 64 scopeid 0x2 
    	ether 00:0d:b9:01:02:c8
    	media: Ethernet autoselect (none)
    	status: no carrier
    	supported media:
    		media autoselect
    		media 100baseTX mediaopt full-duplex
    		media 100baseTX
    		media 10baseT/UTP mediaopt full-duplex
    		media 10baseT/UTP</vlan_mtu,polling></vlan_mtu></up,broadcast,running,promisc,simplex,multicast> 
    

    You have to enter the options in exactly the same way they are output here, without spaces.

    But first do what Scott recommended, use a crossovercable and see if that makes a difference. Hardcoding settings usually causes just problems if not both sides are hardcoded.


Locked