Problems installing to Vortex86SX router.



  • I bought a Vortex86SX system to use as a pfsense router.  The board is a 300MHz system, producing 3 watts of heat.  It has three ethernet ports, two USB, a serial port, two mini PCI, a CF slot, one 40-pin IDE and one 44-pin for a notebook drive.  On the side is a standard PCI slot.  My goal is to use the first ethernet jack for the WAN, the other two for LAN and for now, a D-Link DWL-520, based on the atheros chipset.  First, I used Mac OS X terminal to write the embedded image to a 2GB compact flash card.  When I tried starting up to it, I got a boot failure message.  Next, I tried the same process on a 128MB CF card and it sort of worked.  It went through polling hardware, then failed with a mountroot message.  When I used the ? to display devices, none were found.  After doing some digging, it seems that there might be something in the BIOS that has an impact on whether pfsense sees the drive, but if that were the case, I wouldn't expect it to get that far.  I thought maybe it doesn't like the CF mount point, so I tried a full install on a 2.5" notebook drive, but I got the same result.  In one thread, I read a suggestion to perform a full install on another computer, then move the drive into the intended router device.  That gets a little better.  It makes it through the startup sequence and I get to the 7 option "Welcome to pfsense" menu but when it goes on, I get a "/" and it seems to stall out.  Doesn't go anywhere else.

    Can someone help me figure this out?



  • I understand its not always easy to tell what details are significant.

    What version of pfSense were you using? Version 1.2.3 has been found by a number of people to resolve hardware support issues found in earlier versions.

    @charlesshoults:

    First, I used Mac OS X terminal to write the embedded image to a 2GB compact flash card.  When I tried starting up to it, I got a boot failure message.

    What was the message?

    Next, I tried the same process on a 128MB CF card and it sort of worked.  It went through polling hardware, then failed with a mountroot message.  When I used the ? to display devices, none were found.

    Thats strange. What was reported? The embedded image probably expects the boot drive to be a different drive from the actual boot drive and the startup mount of / can't find the expected drive.



  • When you did the full install: Did you changed the install type to embedded?
    Do you get the / on the VGA?
    The embedded install redirects it's output to the first serial port.



  • The version I've been trying is 1.2.2.  The board I'm using has no video interface, so all output is being viewed through a serial console on XP.    The bios includes a setting for Redirection after BIOS POST, sending the output to com1.  The most recent attempt on the 2GB CF card is using the 1.2.3-RC3 2GB nanobsd image.  It gives the prompt for F1 pfsense, but after I press enter, it drops down a line, shows a prompt but doesn't go anywhere.

    I've used the 1.2.2 Live CD to install on a pair of notebook drives.  On one attempt, I left it with the default option for a single processor and on the other drive, I told it to install the embedded kernel.  The embedded one behaves the same as the 2GB CF, apparently stopping after selecting the F1 for booting pfsense.  The full single-processor kernel, continues on to the 7 option pfsense screen.  I can select to drop out to the command prompt, but if I select anything else, 1-5, I get what would normally be the processing spinner and it will stop with one of the following characters:  \ | / –

    I connected the notebook drive to the 44-pin and an IDE CD-ROM drive to the 40-pin and booted from the CD.  It gets to exactly the same point as the drive with the single-processor kernel and stops.  The CD-ROM drive will eventually spin down and the whole thing sits idle.

    I've not yet tried a Live CD of 1.2.3



  • Well i suppose it could be a problem if the pfSense is trying to send it's video output to the serial port when the BIOS is already using it to redirect in it's own way the VGA output.

    Have you tried to disable the VGA redirection and just write the standard embedded image to the CF card?



  • Hmm.  I haven't tried disabling the VGA redirection, but if I do, I may never get it to work again because the thing doesn't have video output.  I suppose I could test it out, then clear CMOS if it stops working.



  • The board has a couple different options for redirecting the display to serial.  Serial port mode is set up as 115200 8,n,1 on Com1.  Redirection After BIOS POST has options of Disabled, Boot Loader and Always.  When setting it as disabled, the serial terminal sees the POST, up to the point of detecting the hard drive and CD, then a blinking cursor.  Setting it to Boot Loader, shows the F1 pfsense menu and after pressing enter, the blinking cursor.  Setting it to Always, goes through the boot loader, to the 7 option pfsense menu, then a blinking cursor.

    I've tried booting with LBA Disabled and Auto, Block (Multi-Sector Transfer) Disabled and Auto.  Options for PIO Mode are Auto, then zero - four.  DMA Mode has several options, but none of them are disabled.  I've tried SMART Enabled and Disabled and 32Bit Data Transfer Enabled and Disabled.  I've tried OnBoard IDE Operation Mode as Legacy and Native.

    Plug & Play O/S by default is No, but I've tried it with Yes as well, and with Bus Mastering on and off.

    There is also an option for POST Forward To Com1, which I've tried enabled and disabled.



  • I don't recall the "7 option pfSense menu". What does that look like? (It would probably be sufficient to show a couple of the options.)

    Since your system doesn't have a video interface (and presumably no video hardware) its probably best to use the embedded kernel to avoid invoking a driver that thinks there is a VGA device in the system.

    If I recall correctly, the default settings on the pfSense serial port are 8bits, no parity, 9600bps so you would probably want to change the BIOS settings to the same values so there is a "seamless" transition from BIOS control of the serial port to FreeBSD control of the serial port.  I would expect that if you are using the embedded kernel you wouldn't need to invoke BIOS redirection because the booted boot loader and kernel shouldn't be doing any video output of its startup progress.  (But I've never used an embedded kernel so I have no personal experience of this.)


Log in to reply