Squid and dansguardian



  • Hi everybody

    I have a small problem with squid and dansguardian.

    After clear install and basic configuration I needed to install squid and dansguardian. I configured squid with very basic settings (no transparent proxying) and that worked as expected. Then I installed dansguadian but it didn't start at all. After some investigation I added the following line at the top of /usr/local/etc/squid/squid.conf file:

    http_port 127.0.0.1:3128

    After that dansguardian started to work. But when I reboot my firewall that line disappears.

    What I should do to make that modification permanent?

    When I choose from the web interface Services -> Proxy server -> General settings, there is no localhost option available in the Proxy interface setting. What file I should modify that localhost would be available on that list?

    TIA


    Palo


Locked