Atheros Wireless Chipset Issue



  • I have a P3 667 with an aopen motherboard, 1G linksys nic and a 3com 905B nic, a Dlink DWL-G550 and Pfsense 1.2.2.  The wireless is configured as an access point.  The problem is that when I reboot my router, my wireless does not work.  I can get it to work if I disable and enable it in the web interface.

    I have tried using ifconfig ath0 down; ifconfig ath0 up; which work on their own but don't get the wireless working after reboot.  I was thinking I could use a cron job with some sort of command but I don't know what that command would be.  Does anyone know why my wireless isn't working after reboot?   Or have an idea what I could do to get it working on it's own without intervention after reboot?



  • What version of pfSense are you using?



  • I just upgraded to version 1.2.2 a week ago.  I don't remember what the older version was but they both had the same issue.



  • Version 1.2.2 is now comparatively old. I suggest you try one of the recent snapshot builds of 1.2.3 and report back.



  • Version 1.2.3 won't install on my machine.  The kernel won't load because of the BTX loader.  I'm not sure about any details someone just told me that the BTX changed between FreeBSD 7.2 and 7.0 and so I installed Pfsense 1.2.2.



  • I've just updated my router with a new computer.  This is a Celeron proc.  It's actually an old Dell but it seems to work just fine.  This is the 3rd version of pfsense and second or third computer that I'm having the same problem with.  When my router reboots, the wireless doesn't work until I go to the web interface and disable and enable the wireless card.  Someone told me to just automate that process.  I am completely fine with doing that.

    **I just need some help from experts to understand what exactly is going on when I enable and disable the wireless card from the web interface. **



  • your wireless, is it bridged to anything? sounds like a problem that was discussed here before. if you wireless is bridged to LAN, for example, every time you reboot the router the bridge would not re-establish properly.
    make your wireless a separate subnet and route it. worked for me.



  • This is my config.  Does it look right to you?

    type static
    mac 11:22:….
    mtu blank
    bridge with none
    ip addr 192.168.10.1 /24  (my lan is 192.168.1.1 /24)
    gateway blank
    ftp helper unchecked
    standard 802.11g
    mode access point
    802.11g ofdm protection mode off
    ssid myssid
    802.11g only unchecked
    allow intra-BSS unchecked
    enable wme checked
    enable hide ssid unchecked
    transmit power 99
    channel 3  (on this version of pfsense I had to pick a channel to get it to work)
    distance setting blank
    wep unchecked
    wpa checked
    wpa mode wpa2
    wpa key management pre shared key
    authentication open system authentication
    wpa pairwise both
    key rotation 60
    master key regeneration 3600
    strict key regeneration unchecked
    enable IEEE802.1x unchecked


Log in to reply