Freeswitch package



  • I am on pfSense 1.2.2 at the moment and wanted to try Freeswitch package, but according to numerous suggestions and comments, it should only be used on 1.2.3 and later.  If that's the case, why is the package even offered in 1.2.2?  Thanks.



  • If you look at the note on the package before installing it says that is requires 1.2.3. I show it on 1.2.2 because 1.2.3 is still not in full release and I want people to know that the package exists.

    pfSense 1.2.2 uses an older version of FreeBSD. Freeswitch used in the package on 1.2.3 was compiled on FreeBSD 7.2 and that version or higher in the 7.x range.

    So if you compile FreeSWITCH on the version of FreeBSD that 1.2.2 uses then copy it over then the FreeSWITCH package could work on 1.2.2.

    P.S. I'm working on a new version of the FreeSWITCH package as well. I've now called the project FusionPBX and the website is fusionpbx.com. It now works on multiple operating systems. UnixDawg is building a FreeBSD port for FusionPBX. When that is ready I will use that port and wrap a pfSense package around it.


Log in to reply