Yine FTP



  • Arkadaşlar mrb,

    pfsense dmz tarafında bulunan ftp sunucuma local ağdan ulaşabililiyorum. Fakat dışarıdan modem üzerinde tcp/udp 20 ve 21 nolu port yönledirmelerini pfsense ye yaptım pfsense üzerinde ftp sunucuma port forwarding ile yönlerdimeleri yapmama rağmene ulaşamıyorum.
    Yardımcı olabilirseniz sevinirim.





  • Bende bi araştirim bulurbulmaz sana dönerim, bende freebsd üzerine proftpd kurmayı düşünüyorum



  • Gerçi FTP ilgili baya bir sorun yaşayanlar vardı onlar sana benden önce yardım edeceklerdir diye düşünüyorum çünki pfsense arkasına ftp server kurmadım,



  • mrb ftp sunucu olayında bende sorun yaşamışdım aktif mod yada pasif mod şeklinde kuruluyor seninkisi sanırım 20-21 portlarını nat yapmana ragmen çalışmıyorsa pasif mod olabilir eger öyle ise ayarlardan onu aktif mod yapmanı tavsiye ederim





  • pasif mod ise orda portlar vardır zaten o portları senin 20 ve 21 olarak değiştirmen gerekiyor bu şekilde hatırlıyorum



  • LAN-WAN arayüzlerinde "FTP Helper" seçeneği mevcut. Bu seçeneği kullanabilirsiniz …



  • vgumus

    http://translate.google.com/translate?hl=en&sl=en&tl=tr&u=http%3A%2F%2Fdoc.pfsense.org%2Findex.php%2FFTP_Troubleshooting

    ps. biraz garip bir çeviri ama pek te karışık değil yapılacaklar.



  • Bende şimdi Proftpd kurulumundan sonra aynı sorunla karşılaştım
    Lan tarafında ftp girişte sorun yok ama dışardan ftp girmeye çalıştığımda kullanıcı adı ve şifre soruyor kullanıcı adı ve şifreyi doğru yazıyorum ama giriş yapmıyor, Yardımlarınızı bekliyoruz…



  • Merhaba interface alanında WAN kısmına girip FTP Helper    Disable the userland FTP-Proxy application  bu seçenegi iptal edip denermisin



  • @vgumus:

    Yokmu arkadaşlar şu ftpyi çözemeye yardımcı olacak birileri

    sırasıyla yapınız

    -interfaces - wan menüsüne girin. en aşağılarda "Disable the userland FTP-Proxy application " işaretli olmayacak
    -var ise interfaces - opt1 menüsüne girin. en aşağılarda "Disable the userland FTP-Proxy application " işaretli olmayacak
    -interfaces - lan menüsüne girin. en aşağılarda "Disable the userland FTP-Proxy application " işaretli olmayacak
    bunların her birini yaptıktan sonra "save settings" ve "apply" yapın

    -firewall menüsünden rules'a girin. LAN tabında, en tepede olacak şekilde şu kuralı ekleyin.

    action: Pass
    interface : LAN
    proto : TCP
    Source : Lan subnet
    Destination : single host or alias address : 127.0.0.1
    Destination Port Range : from:8000 to 8030
    Gateway : Default
    Description : Ftp baglanti sorunu icin firewall kurali

    bunu da kaydedip, apply changes yapın

    ftp programınızı açıp bir ftp sitesine bağlanın. eğer olmadı ise, ftp programında bağlantı şekli olarak PASV modu seçili değildir. o modu seçin
    olacaktır.

    Sonucu buraya yazarsanız iyi olur, pek çok arkadaşın ortak problemi bu. Ben bu şekilde çözdüm ve kullanıyorum. Eğer herkesin derdini çözüyorsa, bunu yeni bir başlıkta ekran görüntüleriyle filan daha detaylı paylaşırız.



  • @vgumus:

    Merhabalar sorunu galiba yanlış anlattım,
    dediğiniz kuralı daha önce eklemiştim local den dmz tarafında bulunan ftp sunucuma o şkeilde ulaşabiliyorum.

    sorun dışarıdan dmz tarafında bulunan ftp sunucumu ulaşamıyorum. dmz tarafında çalışan ftp sunucusu proftp

    hmm o konuda tecrübem yok
    ama yöntemler şöyle : http://doc.pfsense.org/index.php/Howto_setup_ftp_server_behind_pfsense



  • merhaba dışarıdan ftp sunucunuza ms-dos ortamından ftp komutu ile baglanmayı denermisiniz eger sonuc pozitifse sorun pfle ilgili degildir.



  • Sayın arkadaslar bu konuda yardımcı olacak birisi yokmu ? Benim pfsense sürümünde ftp helper yok bunu nasıl bulabilirim ? Eğer bunu cozersem ftp işinide çözmüs olacagım ?


Log in to reply