Newbie Question



  • Hi,
    I have a Wrap 2C with 1 LAN and 1 LAN.  I have bridged both and created a transparent firewall.  I have one computer connected through LAN and one on WAN through wireless, problem is both can ping the PFSENSE Wrap box and i can ping from PFSENSE to both clients, but clients cannot ping each other. I have even tried disabling the firewall and still no go. Any help would be greatful.

    Thanks
    Beau



  • Unfortunately it is only possible to bridge a wireless interface that is in accesspointmode atm. This is a freebsd-/driverlimitation, not a pfSense one. I guess your wireless interface is in infrastructure or adhoc mode as you have it configured as WAN.



  • Hi,
    I have it in access point mode, that is all i need it for as an access point. The clients are all set to infrastructure mode.  Is there a way to do this?

    Thanks

    Beau



  • There is no problem if the interface is in accesspointmode. I know many people using it this way (including me and other devs). It must be some kind of misconfiguration or you are not running the latest version (though there have not been problems with this feature for a long time). What version are you on?

    Btw, Why is your WAN a wireless AP and clients connect to it? That's kind of a strange setup.  ???



  • Hi,
    The version i am using V1 RC1A.  This is the situation, i have a server connected to the LAN port by ethernet, then i have the Atheros CM9 card for the wireless clients to access the server.  Is this how it should be set up?

    Thanks

    Beau



  • RC1a is pretty old. Please reinstall with the latest snap from this location: http://pfsense.com/~sullrich/1.0-SNAPSHOT-09-12-06/



  • Can i update this through the WEBGUI or do i have to take the card out and reflash it?

    Thanks



  • The version you are running is not upgradeable, however the new version you are going to install is. So yes, you have to reflash the card. The new image has a size of 128 MB btw to support firmwareupdates so you need at least a 128 MB card.



  • OK i have upgraded to RC2a and i still have the same problem, i am guessing it is my rules for the firewall because if i turn off the firewall it works.  This is my situation, i have a computer with ip address 10.0.0.10 connected to the pfsense box on WAN (ethernet port) with 10.0.0.1, the i have wireless serial servers connected on LAN (wireless) 10.0.0.20 and 10.0.0.21.  I can ping from the pfsense box to all on WAN and LAN.  I can ping from WAN and LAN to pfsense box, but i cannot ping from WAN to LAN via pfsense box.
    I have set rules on both LAN and WAN to allow any and all but it still wont work but when i turn the firewall off i can ping all of them.

    Can some one give me some info on how i should set the rules?

    thanks

    beau



  • @hoba:

    RC1a is pretty old. Please reinstall with the latest snap from this location: http://pfsense.com/~sullrich/1.0-SNAPSHOT-09-12-06/

    I told you to upgrade to this version, however now there is an ever newer one at http://pfsense.com/~sullrich/1.0-SNAPSHOT-09-14-06/

    Also make sure you have unchecked "block private networks" at interface>wan.



  • OK now that i am on RC2a can this be upgraded through the web gui?  if not how do i do it?

    sorry for the questions but i dont know much about linux/unix shells.
    thanks



  • No, this version is not upgradable, that's why I told you to refresh with the version I posted which will be upgradeable.



  • Hi,
    Sorry to be a pain again, I have upgraded to the version you told me to and still the same problem which is why i think it has to do with the rules.
    Sorry for posting in the newsgroup, i could not access the forum due to it saying i was behind a proxy.

    Thanks

    Beau



  • Unless you have turned on filtering bridge at system>advanced traffic between the bridged interfaces is not blocked at all so it should be no rule issue. However having any any rules at both interfaces should even make this work with filtering bridge enabled. Please show us your rules at WAN and LAN interface. Also do you see any blocks at status>systemlogs, firewall tab?



  • @bean79au:

    Hi,
    Sorry to be a pain again, I have upgraded to the version you told me to and still the same problem which is why i think it has to do with the rules.
    Sorry for posting in the newsgroup, i could not access the forum due to it saying i was behind a proxy.

    When you login to the webConfigurator, what does "Version" show?  Please show us the value of this box.  It will have 2 rows of text.



  • ok the version is 1.0-snapshot-09-14-06  built on tue aug 1 18:56:52 utc 2006.

    i have the filtering bridge enabled with rules on both wan and lan of  TCP * * * * *.
    I have just tried disabling the filtering bridge everything works ok, but for security purposes i would like to be able to filter where they are coming from and going to if possible.  If not its not too much of a drama.

    Thanks for all your help

    Beau



  • make a rule that alows ping and echo trafic:
    pass interface lan protocol icmp ICMP type any Source any Destination any Gateway  default
    pass interface wan protocol icmp ICMP type any Source any Destination any Gateway  default



  • Sorry,
    I have just tried what you suggested and still does not work.  Due to this not being connected to the internet what should be used as the gateway?  i have tried setting it to 0.0.0.0 and the WAN ip address but no luck either.

    Thanks

    Beau


Locked