Can't set wan ip to static in pfsense 1.2.3 RC1



  • hi, once again a noob question.
    here is what i have in my way…
    ISP —> ADSL Modem/router —> pfsense server —> local users.

    i want to set my pfsense server’s wan to a static ip 192.168.2.2
    my dsl router’s ip is 192.168.2.1.
    but whenever i set my pfsense’s wan ip to static, my local users are not able to connect to internet.
    i want to set it to static so i can forward all ports from my dsl modem to my pfsense server and then i can forward them to any local user.
    please guide me which steps i should take in setting up the wan ip static.

    here is what i have tried.
    i went in Interfaces tab and selected WAN interface. it was set to dhcp by default. i changed it to static and then i put 192.168.2.2 in ip and 192.168.2.1 in Gateway. thats all i did but local users are not able to connect to internet yet.
    please help, thanks alot

    edit: please don’t use any difficult terms in your answer. im new to pfsense as well as in networking. i’ll be thank full if you tell me what to do and how to do. thanks



  • Hello,

    When you set the static IP on your pfsense box what did you set the subnet mask to ( I think it defaults to /32 ) ?

    H



  • @haxs:

    Hello,

    When you set the static IP on your pfsense box what did you set the subnet mask to ( I think it defaults to /32 ) ?

    H

    oh yeah, i have always left it at 32, but now i just tested it by 24 but it is still not working.
    let me give you a little more details.

    whenever i connect my pc direct to the dsl modem, i set my pc to static ip like this
    ip: 192.168.2.2
    subnet: 255.255.255.0
    default gatway: 192.168.2.1
    prefered dns: 192.168.2.1
    alt dns: (blank)

    and i can use internet on my pc with these settings. but whenever i put ip, subnet mask and default gateway to my pfsense it doesn’t work. i think may be one thing is missing? that is prefered dns ??? i didn’t find any option in pfsense to set it,
    plz help, thanks

    EDIT:  and by the way whenever i set my pfsense wan to dhcp, users can use internet



  • You can find your DNS servers in System > General setup, what do you have there at the moment?



  • @haxs:

    You can find your DNS servers in System > General setup, what do you have there at the moment?

    they are empty at the moment. i’ll check by setting dns after few hours. now i can’t break internet connectivity to my users, will update here 🙂 thanks a lot



  • A couple of questions: try getting the ip info in dhcp mode and post that.  e.g. gateway, dns, subnet mask, etc…  Also, is it possible to set the adsl modem/router into bridge mode?  If so, that would make things much simpler for you.



  • If pfSEnse gets its WAN IP address from DHCP it will normally also get the DNS addresses from DHCP also. Hence if you set a static WAN IP you will normally have to configure DNS IP addreses in pfSense.

    You may be able to configure your ADSL modem to always give your pfSense the same IP address (by tieing the IP adress to the MAC address of the pfSense WAN interface). This will mean the DNS IP address will get propagated from the ADSL modem and your pfSense WAN IP address wll always be the same. Works for me!



  • @danswartz:

    A couple of questions: try getting the ip info in dhcp mode and post that.  e.g. gateway, dns, subnet mask, etc…  Also, is it possible to set the adsl modem/router into bridge mode?  If so, that would make things much simpler for you.

    DHCP results in my pfsense WAN interface:
    IP address 192.168.2.10 
    Subnet mask 255.255.255.0
    Gateway 192.168.2.1
    ISP DNS servers 192.168.2.1
    Media 100baseTX <full-duplex>In/out packets 6987844/5670544 (2.65 GB/960.32 MB)
    In/out errors 0/0
    Collisions 0

    im using ZTE ZXDSL 831 series dsl modem/router. it supports bridging. but i don’t know how to work with bridging…
    furthermore, all i need to do is portforwarding with ease. so i want static ip for my pfsense server. i have set my dsl modem’s dhcp server to only one ip, this has solved my problem for sometime. but i think static ip is more better choice here. you can tell me if bridging will solve the problem ?</full-duplex>



  • bridging is always better in this kind of situation, since it removes one level of routing and NAT.  unless there is something that you need to be able to access on the adsl unit, i would just put it it bridging mode and ignore it from then on.



  • @danswartz:

    bridging is always better in this kind of situation, since it removes one level of routing and NAT.  unless there is something that you need to be able to access on the adsl unit, i would just put it it bridging mode and ignore it from then on.

    wow it means my pfsense server will connect to my main isp without any interference of my dsl modem? and i will not need to forward ports on my dsl modem to my pfsense server? please tell me how to do bridging if this is so. this is what i want. thanks



  • i have no idea, it depends on your adsl modem - if it is capable of bridging, there should be something in the docs for that.



  • @danswartz:

    i have no idea, it depends on your adsl modem - if it is capable of bridging, there should be something in the docs for that.

    can you please help by team viewer? or any other remote software please?



  • no, sorry.



  • ok i will manage bridging on my dsl, can you tell me what changes i will have to make in my pfsense after setting my modem on bridging?



  • depends on how the ISP is delivering the connection.  if you have to go on the router to set bridging, look at how its WAN is set and do the same on pfsense WAN.



  • @danswartz:

    depends on how the ISP is delivering the connection.  if you have to go on the router to set bridging, look at how its WAN is set and do the same on pfsense WAN.

    ok, let me show you the screenshots of my dsl modem wan pages. please recommend me how, and where i will setup my pfsense server to start bridging between my dsl modem and pfsense server.

    when i setup bridging mode on my dsl modem. i get these steps with these options.
    Setp 1:
    VPI = 8
    VCI = 81
    Service catagory = UBR Without PCR

    Setp 2:
    Protocol = Bridging
    Encapsulation Mode = LLC/SNAP

    and here the WAN setup finished with bridging mode.

    Other info:
    im using ZTE ZXDSL 831 Series ADSL Modem/router.
    my isp giving me dsl with dynamic ip.

    here are some screenshots of my modem.

    screenshot 1 = the other page under my wan
    screenshot 2 = my wan connections on modem
    screenshot 3 = this is the step 1 that i described above
    screenshot 4 = step 2 of setup.

    please tell me now 🙂

    ![wan connections.JPG](/public/imported_attachments/1/wan connections.JPG)
    ![wan connections.JPG_thumb](/public/imported_attachments/1/wan connections.JPG_thumb)
    ![wan ADSL settings.JPG](/public/imported_attachments/1/wan ADSL settings.JPG)
    ![wan ADSL settings.JPG_thumb](/public/imported_attachments/1/wan ADSL settings.JPG_thumb)
    ![Step 1.JPG](/public/imported_attachments/1/Step 1.JPG)
    ![Step 1.JPG_thumb](/public/imported_attachments/1/Step 1.JPG_thumb)



  • Unfortunately, this does not tell us what the modem was set to before 😞  My best guess is DHCP, so try that…



  • @danswartz:

    Unfortunately, this does not tell us what the modem was set to before 😞  My best guess is DHCP, so try that…

    ahh ok, im sorry for taking you time. if you could tell me what you need to know so i will try my best to tell you all that info?



  • i have no idea - i don’t have your modem or ISP info.  just try DHCP on the pfsense WAN and see if it works.


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy