LiveCD Boot Issue "fwohci0: phy int" repeating



  • Let me start with monowall 1.3b18 works fine on this laptop just can't get pfSense 1.2.2 or 1.2.3 RC3 to work. The thing is when I boot the livecd it starts loading and then gets stuck at "fwohci0: phy int" and it just constantly repeats so I can't see what was occurring beforehand and this sys has no serial interface. I assume its a firewire driver issue but I am not too familiar with BSD. I'm typically a linux/windoz user. Very comfortable with teh cmd line and if I could blacklist the firewire prior to boot I would but don't know how. For the hardware I am running a Averatec 4100 laptop, AMD Turion MT-30, 512MB DDR, 20GB IDE HDD. As previously stated I have monowall currently running just fine but I need upnp for the 360, bittorrent and frostwire. Yea I know I could port forward manually but we have many machines running different OS's and many diff progs so upnp is much easier.
    Oh and this pos laptop has no option in the bios to disable firewire fyi.



  • really no suggestions yet? I'm open to anything, if you think I have to copy it to usb or hdd and then modify something I'd be totally open to that just not sure where to start.



  • Try disabling PNP in the bios if you havent done so already, also if I remember correctly, there should be a few options to choose when you boot up, I think option 2 to disable acpi and I think option 3 for safe mode, you could try all of the above and see if you make any progress, lastly a bios update might solve your problem, apart from that nothing else I can think of.



  • Thanks for the suggestions but this bios has no PNP option either. It has next to no options but I have the latest bios rom and have disabled LCD power save and auto dim, and Touchpad support. I also have disabled removable devices and set CDRom as first device and HDD as second. Other than that I really only have AGP Gart and passwd options. As for the Live boot menu options I've tried them all to no avail. In the mean time I've also tried 1.01-1.2.1 and have the same issue there. Gonna grab a BSD disk next and go from there. Weird since its based off monowall that pfSense won't work but monowall does.


  • Rebel Alliance Developer Netgate

    Have you tried to disable firewire in the BIOS?

    Seems like the next likely step.



  • The bios doesnt have that option nor does it have Upnp or anything else useful.


  • Rebel Alliance Developer Netgate

    Is the firewire port on the motherboard?

    I don't think I've ever encountered a motherboard with a built-in firewire port that couldn't be shut off in the BIOS somewhere

    You might also be able to disable it with device hints at the loader prompt, but that is less than ideal.



  • Yea its on the mobo but the bios is useless for much other than boot order and clock settings. I don't have any firewire devices connected but if you could tell me how to blacklist it or disable it at the loader/cmd prompt i would be very happy.


  • Rebel Alliance Developer Netgate

    At the main boot menu, the one with the ASCII logo, press option 6 to get to a loader prompt.

    At the "OK" prompt, type:
    set hint.fwohci.0.disabled="1"
    boot

    If that lets you get farther, you can add a line to /boot/device.hints with just this:
    hint.fwohci.0.disabled="1"

    That will get reset after an update, so be careful when updating pfSense in the future.

    If that does not help, then it probably isn't a firewire problem and that just happens to be the last device printed before it locks up.



  • Thank you very much for that information thats what I have been looking for. I can't try it ATM cause the internet needs to be up but I will give it a go later tonight and see if it works.



  • Despite your advice it appears the display driver fails somehow on my sis chipset (junk btw) so I went ahead and installed it on a VM. Using an nLite'd XP Pro install for minimal host overhead I have had great success running pfSense 1.2.3-Release with virtualbox. After bridging the adapters and mirroring the WAN mac it performs great, especially squid and upnp. Hope to get it on some real hardware soon. Thx again.


Log in to reply