Alix 2d3 with CF install: m0n0wall works, pfsense won't boot


  • Hi there,

    I'm unable to boot any pfsense image on my new Alix 2d3 (BIOS 0.99h). I tried with m0n0 1.3b18 and this worked. But pfsense 1.2.1, 1.2.2 (embeddd) and 1.2.3-RC3-1g-nanobsd won't even boot. Flashed the image onto the 1GB CF-card on Windows, Linux and Mac OS X several times.

    I have a USB-to-serial thingie. What makes me worried is that I can't even press "s" while RAM is counting up, it just doesn't do anything.

    9600 8N1

    Welcome to minicom 2.3
    
    OPTIONS: I18n 
    Compiled on Feb 25 2008, 03:47:42.
    Port /dev/ttyUSB0
    
                     Press CTRL-A Z for help on special keys                                              
    
       ��t..cSDD//ii338866  bboooott                                                                      
    
    DDeefll 00:                            
    

    38400 8N1

    Welcome to minicom 2.3
    
    OPTIONS: I18n                                               
    Compiled on Feb 25 2008, 03:47:42\.                          
    Port /dev/ttyUSB0                                           
    
                     Press CTRL-A Z for help on special keys                                              
    
    17r 044A CF 1GB                                                                                       
    Phys C/H/S 1966/16/63 ���x��xx
    

    I'd appreciate every help.

  • Rebel Alliance Developer Netgate

    By default the ALIX board is 38400 for the BIOS settings, so you have to use that speed to set them. I typically do the first connect at 38400, go into the BIOS, set it for 9600, CHS mode, then save and adjust back to 9600/8/n/1.

    Neither one of those outputs looks good though.

    Have you been over the embedded-related choices on this page?
    http://doc.pfsense.org/index.php/Boot_Troubleshooting