Experienced crashes / bugs in 2.0 ALPHA



  • hi, i just installed 2.0 ALPHA. and got these problems all the times i reinstalled it.

    1. GUI is so slow as compared to 1.2.3
    2. GUI get stuck some times and no way to get to it until restarting the server.
    3. it does not reset all the settings to factory settings :( , i was playing around with 2.0 ALPHA to know the things and i just selected the gateway of my LAN to the ip of LAN. i.e my LAN IP 192.168.3.1 and i set my gateway to 192.168.3.1 (same as LAN ip, (by mistake)), and i lost access to my gui for ever :(, i tried to reset to factory setting but it didn't solved this problem. and i had to re-install it from start.
    4. i was setting a new queue in trafic shaper, and queue were not being saved. i put all informations in queue and then press save. but it was not saving. (i had to go to other pages of gui and then came back to creat queue, this solved the problem.) it happened to me many times with queue creation and rules creations.

    this is it for now, i have experienced those things. all other things are not very big trouble for a new user like me but the biggest trouble i had again n again is point 3, i have to re-install 2.0 again n again for different tests for my networking environment. please someone tell me if i can reset everything in pfsense 2.0 without re-installing it.
    i will be really thankfull.



  • Congratulations! You found some errors like everyone of us. But calm down, its alpha-alpha, or say its buggy-buggy? No, not at all.
    If you want to have a secure fresh setting after some config-errors, you should first after a new install save your config.xml. You can find it easily in /conf. Save it, restore it and reboot. Et voila, all is like a fresh install.
    This should resolve at a rush your problem 3.
    To get rid of No 2, you only have to go to the shell and restart the webgui via command 11.
    If you want to know what happens to all other errors you will find, have a look here:

    https://rcs.pfsense.org/projects/pfsense

    Here you will see all work which is done every (or mostly) day by the people who make it real. So be happy and feel welcome to the club… You will learn a lot about your firewall, freebsd and the nice people who will help you to have a secure network-environment.


  • Rebel Alliance Developer Netgate

    There are plenty of things that still need refining in 2.0, it's hard to say for sure how well it will work on any given day, especially since it's alpha-alpha, not even just alpha.

    The slowness you are experiencing is likely due to the fact that 2.0 includes many debugging options in the kernel which slow down all operations in general, but will make it easier to get debugging information for developers.

    As igor said, watch the commit logs, and also check http://redmine.pfsense.org and see if you have encountered any known issues. If you can reliably reproduce an error condition, document it as well as possible and open a ticket, but don't open a ticket unless you have a lot of supporting detail. Usually it's best to post first to the forum how to reproduce the bug exactly (step-by-step) to see if others have the same issue.



  • lol one more latest thing to share. i just upgraded the firmware and now i can't see gui, whenever i go to my gui page this comes to me all over the screen :(

    ‹������ÔZýrÛƵÿ[|Š’)AŠH9qJPÆRì^7ñÇXjÒŽ¤z@)ÂXJàU5s_ä¾\Ÿ¤¿sv�)ÉI;íL«ƒÀî9gÏ÷9»ëÃÝïߝœýéýK1W‹T¼ÿÃñ¯O„3ôýŸŸøþ÷gß‹?þÏÙ›Å؉³"ÌÊD%y¦¾ÿò­ÓÙqæJ-'¾{{ëÝ>óòâÊ?ûàWDlLØæu¨Z¨^¬bç¨sH@ô#Ãø¨³s¨•Ê£åìTf¥ôÒ< S1æ[|–óiñ¡¯±*ßj9”Y%7s’gJfjx¶^JGDú+p”¬”O«ˆh¥TARæÃo¾ùúÛáØ>­ž&Ùµ(düíÿþ?\.S9Tù*šPÁ˜rFs¾šË…,ýå¬$>?fWþ6¸·Ì®ò¨#¶þZË8¥Z§²œK©MÜyŒtšzQY:b!ã$ œ0M™_Kwg§sÈ„„‚ÈFRB8êx…Ê—/¤Ÿ»8)—i¸žL¡Öë{='úfVô7çæ2¹š«ÉxYä7²˜¥ùídžÄ±ÌfÐé°LþWÒ,1y˜æE,‹!ó2ež&ñ»Mb5ŸŒ„F(ƯHé!ù‘Žïaq•dÃTÎÔäk¦Ê@üÐ@E T0gjŸHÑCòƒ_C¢nQ}¦©TÑÀó«†ß^À <£è!ùÁ¯!y­’Ö*µ0ü.ñ±!ξ^˜°‹†¿j:̃¦£å5t¶2„¾¡”%qQjáé[òhHk„šM&ZîXjÀopg,BøECTkˆ‰ò¨&ªy6D «šhQÕÆ1T+RN}7 óµ/óiHj } „–¨ÀöC"ÆDC€‡GˆG¼ƒ¨’®*ÖUÅbUd¼‡ëÍk".SaÝX"Ëc¨@Z fm6­MCÚ¢p_|h3ÖÔæÕP0ê£âŽ(°+¶MÅŒVš1¶bUê‰R‹À¡yg¯Ñ¶ÖP! Q/@ŽÁÜ0‚d?áo©)Ð@¨_µh4Pé×â«;“[¬Vµ'é"¡¥ñ=n,Úsà[b$F6Cð¹›,–y¡ÂL™Qá÷û¾NO‡>'¤£ŽÍ’&.‹$CÚ}*gÓ\©|aÒ#ýè:MŠ,Ïä=¨¶èGE²Tm’ŸÂ›°äQdãÙ*‹¨pŠ·ÉL­Oæ2ºv{wdæîÆy´Z jyWR½LQ\2u¼~‹¿þU4sQ!C%Ít K!ÕªÈÜY˜–²wÐIJ.Ôº‹‰ï)Y*÷âåñú,¼z.¤ÛæñºÛ;]zYK#J3÷EQ„koYä*'%yËU9‚l•¦½»Gç¬|$”.Njž”çôðR™]©ùe€4Ï‚–Xï�µ–ÙoAôîï;v¸X+б¥,>ä«,–±[ÊTF*/·I4L¯Qžâ+_*¬}",Q¬“J™ßé ʧp’!oñ•,VFÓ°,itjF”þ=è*4J+u0Ë°€y#$ÈFÙžS9,³!?½ÖŸÓëM$=zß‘°—�a0,~ó/Õ»™ëèôãôŽ‚‘YƒHXX.ÓD¹Žp Ró,/Ü$$‡ cT}ìíi!½TXœ'—ÍB_è5„á™± ©ÃŒC+= ã|ñüùs#ÄiåfeXì׈X.ò\ÍÛ"2±ÐÓú~“T®5­‘õž¬F(­\P[Ä:L«-ã0}Ÿò;hß4š¨qïTÀ2Lù§±Ó&8º)³”"ó®H Ö¢[†§;¶Tml²\8½ÃQO¶¡ÝÔ(äIF€Ñ¸É&ù†JQSy ¸ÎiF-ôS¢L7D™Ö‚?ÊtC”鯅0Q6ÉkQˆJ# ÅÄMФKd´S“êì�§!°4¸±AÑi‚%åц!g'î‰q|Ìm¬{ƒP0ÙÂ8 CœåK=m½ÓÀÙœÓÀO E%ŸC™ÖþÝÎv 32L#›Ú8;ïÊÔ["gÉØ$ ’…y’Æo‘ÇmÊ ‚1ËÆ”Íõ´E ‚g†�’Ô¥�Ï’¢T'DŒ«ÂOaj#›À�PÈö Aë"}jp#ˆ%'¦j¹2gf“ÍÇWfÏlL‡w&ÆY5�¶U2‹õuÓuð :6i­ V6pZS÷[Ù ´Õò b[§”>©Hjō[Š#è ‚ªÅÓùüG´¾C½KI#áìM#* •þ>‹þ!ÁnìóøZ>¢¤ß(iÑI •”f›j ÿ"W&ç²t¡PZG¤É"øjжᔠÈ%1kÒgiï³wÂYa^.ªÔPÓJ[P˜–ÓäÆŒ™°Î0 £ë«‚Êü •ô€©Ú1*\€%Z6"w­ZÆÜ‘ŒUkí({"Ѻ®¬M¶Vá‚£As⾆älx1[/quote]



  • @_igor_:

    you should first after a new install save your config.xml. You can find it easily in /conf. Save it, restore it and reboot. Et voila, all is like a fresh install.

    well, firstly tell me how to save config.xml. then how can i restore it?
    if all this is done by web gui then it has no use as in a trouble i can't use gui whenever its setting went wrong, if config.xml can be backup and restored from the server consol then it would be much usefull for me and for others like me. (sory for bad english)

    EDIT:  Im happy to tell that i just downloaded and installed the latest available release i.e pfSense-2.0-ALPHA-ALPHA-20091130-1932.iso.gz . and it can reset all settings to factory default :)
    thanks to the team.



  • To save config.xml, you have to do it via the console: Press 8 at the menu and you are in. Then copy config.xml to whereever you want or do a copy like config.save. Then only copy the config.save back to config.xml. Its all done via console. You can do it too via the web, its similar.


  • Rebel Alliance Developer Netgate

    You save the config.xml by going to Diagnostics > Backup/Restore and performing a backup. That will give you a copy of config.xml which you can use to restore everything, even the RRD graph data.

    The garbled code from the WebGUI was fixed last night, it was a result of a bug in how lighttpd was serving up gzip compressed data.



  • Bug no 3 was fixed on saturday and the same with reboot from console menu. (same bug).



  • @lsf:

    Bug no 3 was fixed on saturday and the same with reboot from console menu. (same bug).

    New Bug:

    i am trying to set my WAN to static, it doesn't accept gateway, whenever i try to put my ip and then gateway and then save it. it says,

    The following input errors were detected:

    * A valid gateway must be specified.

    im using this version of pfsense 2.0 pfSense-2.0-ALPHA-ALPHA-20091201-0005.iso.gz
    here is the screenshot of it when i press save button,,,

    (im goin to download and install the latest available) will update here if that works.

    ![gateway prob.JPG](/public/imported_attachments/1/gateway prob.JPG)
    ![gateway prob.JPG_thumb](/public/imported_attachments/1/gateway prob.JPG_thumb)



  • ok, i have downloaded and installed the latest available release i.e.
    pfSense-2.0-ALPHA-ALPHA-20091202-0909
    released at
    pfSense 02-Dec-2009 14-22pm

    but the problem is same, i can't assign a gateway to my WAN,

    here is what i have,,,

    Internet        –->          DSL Router          –->            pfsense server            –>        Users
                    [WAN=public ip - LAN=192.168.2.1] [WAN=192.168.2.2 - LAN=192.168.3.1]

    i want to assign static ip to my wan, and i put 192.168.2.2 as ip and when i put 192.168.2.1 as a gateway, it gives an error i.e.  "A valid Gateway must be specified" and it doesn't save it.

    please help me if im wrong. and correct it if its a bug…  thanks



  • two more bug in latest release…

    bug 1:
    whenever i want to creat a new user in user manager, it gives the following error and then the upper menu of pfsense disappears or becomes transparent.

    Error:

    Warning: chown(): Unable to find uid for whisper1 in /etc/inc/auth.inc on line 306 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/auth.inc:306) in /etc/inc/functions.inc on line 69

    where whisper1 is the user account that i just created.
    it happens every time i add any user,

    bug 2
    per user limit in captive portal doesn't work.



  • redmine.pfsense.org create a user and bug report worth of being considered as such.

    My mom does not know how to cook style of reporting is useless!


Log in to reply