DynDns: Current WAN IP - Internal IP ????



  • Hi,

    I configured the no-ip im my pfsense (1.0-SNAPSHOT-09-14-06 built on Thu Sep 14 17:27:35 UTC 2006) but the WAN IP dont refresh in NO-IP, i look in the logs and find this:

    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: updatedns() starting
    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: _detectChange() starting.
    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: Current WAN IP: 172.30.30.20
    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: Cached IP: 172.30.30.2
    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: cacheIP != wan_ip.  Updating.
    Sep 14 16:35:40 fw01 php: /services_dyndns.php: DynDns: DynDns _update() starting.
    Sep 14 16:35:41 fw01 php: /services_dyndns.php: DynDns: DynDns _checkStatus() starting.
    Sep 14 16:35:41 fw01 php: /services_dyndns.php: DynDns: Current Service: noip
    Sep 14 16:35:41 fw01 php: /services_dyndns.php: phpDynDNS: (Error) Invalid IP. IP Address submitted is improperly formatted or is a private IP address or is on a blacklist.

    The IP 172.x.x.x is the WAN IP address of my ADSL modem but not my PUBLIC IP.

    ex:

    –--------LAN IP--(PFSENSE)--WAN IP------------------172.x.x.x-(Modem)-Public IP--------INTERNET
          192.x.x.x                  172.30.30.20

    I need that my PUBLIC IP be send to NO-IP and not the WAN IP of Pfsense.

    Somebody can help me ?

    PS: Sorry about my english.

    Thanks



  • Then turn off NAT on your modem and allow it to give pfSense the public ip.



  • …or use a dyndns updater behind your firewall that connects to an outside server to ask what it's current public IP is. Nearly all providers have these as free downloads somewhere at their site though I would go with scotts suggestion. It's less problems having the pfSense at the real WAN.


Locked