New install IM-GM45 can't mount root on first boot

  • All,

    I'm trying to install pfsense on a new setup using multiple snapshots of 1.2.3 RC3.  I'm installing on an MSI IM-GM45 mobo and Intel core 2 duo 2.8ghz processor.  The live CD boots normally to the counsel.  After install, it boots up to " trying to mount root from ufs:/dev/ad4s1a".  It fails multiple times then allows me to try manually mounting it.  I'm at a loss of why it won't mount other than the root file is not present in that location.  Unfortunately, I don't know where else to look for it if it even got installed to start with.  I know the CD is ok since I tested it on a known working setup.  I tried installing the multi-core (which I need) as well as the single core kernel as a test to no avail.

    For shits and giggles, I even tried installing pfsense 2.0.  It failed as well but for what appeared to be different reasons at which point I gave up on that approach.  At some point I would like to experiment with 2.0 again, but I must have a production release at the moment.

    Thanks for the help,

  • When you installed, the hard drive partition you installed to was ad4s1a. Perhaps you have (even inadvertently) changed something so that the hard drive partition containing the installation is no longer ad4s1a. Maybe you have changed a relevant BIOS setting or changed the configuration of drives connected to the system. Maybe you have a hard drive problem resulting in a mount error of the root partition.

    It might help to have the startup output or at least the screen when you get the report of the mount failure.

  • I don't think anything was changed as I did nothing other than remove the CD before rebooting.  Though it doesn't make sense to me, is it possible the physical location changes if a cd isn't detected in the drive?  I'll write the screen output tomorrow and post if I don't get any other input.

    Thanks wallabybob, seems your always amongst the first to answer any problems people bring!

  • @33_viper_33:

    I don't think anything was changed as I did nothing other than remove the CD before rebooting.  Though it doesn't make sense to me, is it possible the physical location changes if a cd isn't detected in the drive?

    Its possible the BIOS might "disable" a disk controller with no connected drives, effectively renumbering the drives. Modern chipsets typically have a number of disk controllers to support SATA and IDE drives. They often have options to change the order in which the controllers are seen (SATA first then IDE or vice versa) as well as options to enable/disable RAID extensions etc.

    Here's an extract from my startup output. (I have two solid state disk modules plugged into DE connectors on the motherboard.)

    ad0: DMA limited to UDMA33, device found non-ATA66 cable
    ad0: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad0: 955MB <transcend 20071207="">at ata0-master UDMA33
    ad2: DMA limited to UDMA33, device found non-ATA66 cable
    ad2: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad2: 955MB <transcend 20071207="">at ata1-master UDMA33
    WARNING: Expected rawoffset 0, found 63
    WARNING: Expected rawoffset 0, found 63
    Trying to mount root from ufs:/dev/ad0s1a

    Note the report of the drives: ad0 and ad2 and the root mount of ad0s1a.

    On your system you should see a drive report, note the name. If its not ad4 its likely drives have been renumbered since your install. If thats all the problem then you should be able to specify the correct partition and have / mounted and then go and edit fstab to specify the correct location of the root partition when there is no CD connected.</transcend></aborted></ready,dsc,error></transcend></aborted></ready,dsc,error>

  • The HDD isn't changing renaming itself.  i get ad4: seagate drive which is the only hdd in the machine.  the cd remains ACD0: slim DVD A DS8A2S/645D.  The next two lines get repeated several times as it tries to mount root.

    AD4: FAILURE - READ_DMA STATUS = 51 <ready, dsc,="" error="">ERROR = 48 <icrc, aborted="">This repeats about 8 times then gives me the manual mount option.  I'm still completely lost.  The only thing I should add not that it would make a difference is the CD is on a SATA bus while the hdd is on a ide bus.  A bit backwards I know but I had the drive lying around and would rather ware out a junk drive before getting a new one.

    Thank you for your continued help,

    EDIT:  I tried another drive with no luck.  I also went back and retried installing 2.0 again.  This time it doesn't find a suitable HDD while booting off the CD drive.  Interesting problem.  It must be something to do with the controller.  Any ideas?  I don't think its lack of support as I can format and install in 1.2.3 rc3.

    Please, does anyone have any ideas?

  • All,

    Today I tried installing on a full size hard drive with full success.  Don't know why it won't utilize a laptop hdd that has been running in my machine for the past year or the spare I had.  I'm using the same cable for both drives.  The motherboard has a 44 pin IDE interface and the cable has 2 X 44pin IDE connectors and 1 X 40pin IDE connector.  I tried plugging the 2.5" drive in the normal way via 44pin connector.  I used an adapter and the 40 pin connector.  I even used the 44 to 40 pin adapter than a ide to sata converter.  In each case i got the same error.  This drive worked just fine on another motherboard.  I don't get it!

    I really need to use a 2.5" HDD for this system.  Does anyone have any ideas as to what could cause this?  Could it be a setting in bios?  I tried enabling and disabling every setting in the ide controller with no luck.  The 3.5" drive natural had S.M.A.R.T disabled which I tried replicating with the 2.5" drive.  No luck.

    Thank you four your continued help,

  • Perhaps you have a cable problem between hard drives and motherboard or a bent pin. Have you tried booting a Linux live CD and accessing the drive? (For example, dd the whole drive to /dev/null to verify Linux can read it all.)

    You don't say why you want a hard drive. If you don't need lots of space maybe an option would be a solid state disk module such as Transcend's (for example see for a link to a datasheet). These are available in a variety of sizes and with 40 or 44 pin IDE connectors. 1GB costs under US$25 from I've been successfully using two of these in my pfSense box full install, not embedded) for over 18 months now. I use one as a backup drive. These are small and generate minimal heat, vibration and noise. Perfect for a small and light box.

  • I need to use a filtering proxy, clamAV, and I like to use snort for added security.  We are in a remote location stuffing 36 people on 2 satellites.  I'm hoping to add another satellite but for now its all about bandwidth management.

    I don't think its the cable since I'm using the same cable on a working full sized drive.  Would like to just use the 3.5" drive but it won't fit in the case.  I'll try linux here in a few.

    Thank you for your continued help,

  • Maybe you should try an SATA 2.5" disk instead of an IDE? Further: disable all not needed features on the board, such as sound, audio and perhaps USB.