Pfflowd Not Able to Start



  • I have been trying to get pfflowd to run on my 1.2.3-RC3 installation without success.  I have searched and read through this post regarding the same issue - http://forum.pfsense.org/index.php/topic,14836.0.html  However I did not have the same success as kalidin.  I have followed his process and solution, but still cannot get the pfflowd service to start.

    Regarding the startup script mentioned, mine looks likes this:

    #!/bin/sh
    # $FreeBSD: ports/net/pfflowd/files/pfflowd.in,v 1.1 2008/05/26 09:51:09 rafan Exp $
    #
    
    # PROVIDE: pfflowd
    # REQUIRE: LOGIN
    
    #
    # Add the following lines to /etc/rc.conf to enable pfflowd:
    #
    # pfflowd_enable="YES"
    # pfflowd_host="<host>:<port>"
    #
    # DO NOT CHANGE THESE DEFAULT VALUES HERE
    #
    
    . /etc/rc.subr
    
    name=pfflowd
    rcvar=`set_rcvar`
    
    load_rc_config $name
    
    # set defaults
    
    pfflowd_enable=${pfflowd_enable:-"NO"}
    pfflowd_host=${pfflowd_host:-"127.0.0.1:2055"}
    
    command=/usr/local/sbin/pfflowd
    command_args="-n ${pfflowd_host}"
    extra_commands=reload
    
    stop_postcmd=stop_postcmd
    
    stop_postcmd()
    {
      rm -f $pidfile
    }
    
    pidfile="/var/run/${name}.pid"
    
    run_rc_command "$1"</port></host> 
    

    I am no BSD/Linux expert at all, but the line regrading adding the lines to rc.conf to enable pfflowd catches my eye.  And of course I can't find that file, because it appears it has been renamed to rc.start_packages - at leas the same code is there as referenced by kalidin.  So, I am curious if I need to add these lines to this file?  And if so, where?  ???

    Any help is appreciated.  Please…..?


Log in to reply