Can't edit or add gateway



  • With the snapshot 2.0AA Dec 6 00:13:

    When i want to add or edit a gateway ik get de following message:

    Parse error: syntax error, unexpected ',' in /usr/local/www/system_gateways_edit.php on line 97

    Has anyone else noticed?



  • Yes - I just installed today and noticed the same issue.  You can set your main WAN gateway by using the System > Setup Wizard…

    If you want to set other gateways, you'll need to wait for a fix.

    Personally, I want to change the Monitor IP on my gateway so the quality graph will show some useful info...



  • You could try commenting out lines 96,97,98…those lines are just a check to see if the GW is in the same network segment as the IP if I remember right.



  • Fixed.



  • Well i have the same problem mi snapshot is december 5 I don't know when will be ok..




  • It is fixed in git now, not sure if it's in any snapshots yet, though.

    I updated mine about 6 hours ago by editing /usr/local/www/system_gateways_edit.php with what was placed in git, and I can now confirm that it is fixed.  I did it right as I left the house this morning, though, so I don't know if the Monitor IP address I set works or not with the quality graph.  (I expect it works fine, but just haven't looked yet)



  • Looks like the original issue described in this thread is fixed, as I can get to the add/edit gateway screen in the 12/12/09 build.

    However, it seems to be ignoring the "Interface" selection when adding a gateway. When I attempt to add a default gateway and select the LAN interface, it tells me the address (10.10.254.1) is not on the interface's subnet (10.10.0.0/16), and the interface selector changes back to WAN.

    For that matter, I've just tested, and it gives the same error when attempting to add a gateway on the WAN interface too. WAN subnet is 10.90.90.0/24, and I tried to add 10.90.90.92 as a gateway. No dice.



  • To update my previous post; I've just updated to the 12/13 snapshot and the situation is a little different. I can now properly add a gateway. But creating a new default gateway doesn't change the system's routing table at all.

    Here's what I'm trying to accomplish for testing purposes:
    I don't have anything connected to the WAN interface yet, still waiting for my DSL modem to arrive tomorrow. So I'm trying to get pfSense itself to connect to the internet via a gateway on the LAN.
    So I add my existing gateway to the list, applying to the LAN interface, and marked as default. It doesn't actually change the system's default gateway.

    It seems like the WAN gateway is always default, whether it's marked as such or not.

    Now that I can at least add/edit gateways properly, I've been hacking around this by adding a static route for 0.0.0.0/1 to my temporary gateway.



  • Cn you report this on redmine.pfsense.org



  • @ermal:

    Cn you report this on redmine.pfsense.org

    Sure. Reported as #217.


Log in to reply