Squid Error with havp



  • For some reason my IP keeps changing and forces a reload of squid and havp.  I keep getting the following errors in the system log.  Can anyone offer some advice as to what these errors mean, and if this effects my system's vulnerability?

    Thanks

    Dec 6 13:30:44 dnsmasq[507]: using nameserver 166.102.165.11#53
    Dec 6 13:30:44 dnsmasq[507]: using nameserver 166.102.165.13#53
    Dec 6 13:30:44 dnsmasq[507]: reading /etc/resolv.conf
    Dec 6 13:23:08 check_reload_status: updating dyndns
    Dec 6 13:23:08 kernel: pid 54405 (squid), uid 0: exited on signal 6
    Dec 6 13:23:07 squid[54405]: No port defined
    Dec 6 13:23:05 php: : SQUID is installed but not started. Not installing redirect rules.
    Dec 6 13:23:07 Squid_Alarm[54399]: Attempting restart…
    Dec 6 13:23:07 Squid_Alarm[54397]: Squid has exited. Reconfiguring filter.
    Dec 6 13:23:05 php: : SQUID is installed but not started. Not installing redirect rules.
    Dec 6 13:23:03 havp[54304]: Process ID: 54304
    Dec 6 13:23:03 havp[54291]: –- All scanners initialized
    Dec 6 13:23:03 havp[54291]: Clamd Socket Scanner passed EICAR virus test (Eicar-Test-Signature)
    Dec 6 13:23:03 havp[54291]: –- Initializing Clamd Socket Scanner
    Dec 6 13:23:03 havp[54291]: Use transparent proxy mode
    Dec 6 13:23:03 havp[54291]: Running as user: havp, group: squid
    Dec 6 13:23:03 havp[54291]: === Mandatory locking disabled! KEEPBACK settings not used!
    Dec 6 13:23:03 havp[54291]: === Starting HAVP Version: 0.88
    Dec 6 13:23:03 check_reload_status: reloading filter
    Dec 6 13:23:02 php: : Configuring slbd
    Dec 6 13:23:02 kernel: pid 54280 (squid), uid 0: exited on signal 6
    Dec 6 13:23:02 squid[54280]: No port defined
    Dec 6 13:23:02 php: : pfSense package system has detected an ip change 71.29.176.253 -> 75.90.168.36 … Restarting packages.

    I also get an error when trying to look at certain websites where the HAVP error page comes up saying :

    HAVP
    The following server is down:
    Could not read headers

    If I refresh the pages enough, the website will eventually come up.



  • Dec 6 13:23:02    squid[54280]: No port defined
    Check squid config and press Save button.


Log in to reply