Xbox Live Issue



  • Okay I'm a Verizon FIOS subscriber.  I use PPPOE to connect.

    I'm having issues connecting to Xbox live.  I keep getting marked as strict.  Under ipcop I just opened ports 88 and 3074 and things were just fine.

    All I'm doing here is creating the NAT rule TCP/UDP for port 3074 and the same for port 88 and pointing them to my internal lan ip for the Xbox.

    I still get marked as strict when I run the network test.

    Any ideas what's going on here?  Vonage appears to work without any tweaking so far.  Wish the Xbox live service was that tolerant.

    Thanks in advance.



  • Try the Universal PnP package. You can install it from system>packages or see this thread: http://forum.pfsense.org/index.php/topic,551.0.html



  • @hoba:

    Try the Universal PnP package. You can install it from system>packages or see this thread: http://forum.pfsense.org/index.php/topic,551.0.html

    You will want to use the newer binary that is in testing.  XBOX support was recently added to the upnp package but the binary has not been updated on our site as of yet.

    You'll find the URL to the updated binary in the thread above.



  • I dont really see that as a solution.  I dont trust anything opening ports on the firewall except rules I put in myself.

    Can someone just help me with why opening the two above ports does not appear to be working?



  • @coreyt:

    I dont really see that as a solution.  I dont trust anything opening ports on the firewall except rules I put in myself.

    Why?  It opens only the ports you need and its actually safer in this case because it will close them back down when the xbox is not in use.

    I also had panic attacks about upnp but afer reading the c code and understanding how it works, I run it on my firewall 24x7 now.



  • I recommend using the upnp solutions for the xbox too. Other possible solution is to add a static port for the outbound NAT of the xbox. Search the forum for "static port" to find similiar threads (it can be an issue with SIP too sif there is no stun server in use).



  • Is there a place to replace the binary from the one in RC2 and then click install or is this one a manual install?



  • For now it's a manual install like described in the upnp bounty thread until the package gets updated to include the new binary.



  • So doing the package install included and then copying the new binary over the old one will not work?



  • That's how I did it.

    Installed the package, activated it. Just a note on that, the menu to enable it will appear in the "Diagnostics" tab after you refresh the WebGUI. Go to the "Miniupnpd" section, and on the settings page choose the interface you want it enabled on and then click "Change". (Just in case you don't figure it out…I got stumped on that one for a bit...doesn't seem like a logical place for it to me...)

    To update the binary, stop the service under "Status">"Services", click the stop icon. Then copied the newer binary over the old one, you can either do it via ssh or, via "Diagnostics">"Command". The binary is in /usr/local/sbin. You may have to fix up the permissions to make sure it's executable afterwards, mine is set to 755, I just made sure it was like the rest of the binaries in that section.

    That should get you in business!!

    JC



  • We'll that's what I did.

    Had to put the 360 on automatic ip again instead of static.  It said it was open when I ran the test that time.

    However when I fired up chromehounds I could not join any free battles for some reason.  Voice chat did though.

    I'll try BF2:MC later today and see if it has any problems.



  • hi

    pfsense runnig well with xbox live … !
    it is an simple trick what you have to do to get the result "moderate" at the nat test.

    at the firewall -> nat -> outbound sektion.

    choose the automatic generated nat rules.
    klick edit
    the enable "static nat" .

    save

    and , if you have the redirect rules , you have an working pfsense box.

    holger


Log in to reply