Package-update pain



  • After updating pfsense to the actual alpha (12-06-2009) i get errors when pfsense tries to update packages. Deleting the files in /usr/lcal/pkg solved the most problems, but one with squidguard isn't solveable to me…

    When trying to reinstall (package is still listed under installed packages) i get this:

    Fatal error: Cannot redeclare is_url() (previously declared in /etc/inc/util.inc:1108) in /usr/local/pkg/squidguard_configurator.inc on line 1770

    Looking in /usr/local/pkg it shows some new squidguard-files. Deleting them and rebooting to try a new install results in the same.
    When i try to delete the package, its the same error i get.
    Is there any hint outside to get rid of this? Thanks much!



  • I just fixed this.  Please delete everything in /usr/local/pkg/* and install again.



  • I tried this with no success. I will do a new install due to the early state of release. Maybe it will be better… But thanks much for your quick help! I think its a problem of squidguard, all other packages have been gone after deleting and deleting their entries in config.xml.


Log in to reply