[SOLVED?] Can't update alix bios - serial error?



  • Hello to everyone!
    I'm trying to install pfsense 1.2.3 nadobsd on my alix 2d3. I red here http://doc.pfsense.org/index.php/ALIX_BIOS_Update_Procedure
    but i'm stuck at "ah the promt type" because i have no prompt but a lot of strange charachters.

    My configuration is:
    Windows Vista Business SP2
    Tera Term Pro
    Nullmodem cable
    Port speed set to to 38400 both on tera term and OS.

    I'm feeling stupid, where i'm wrong?



  • strange charters almost always mean you are not using the correct baud rate.  try using 9600,N,8,1 or 19200,N,8,1 and see if that helps.

    Roy…


  • Rebel Alliance Developer Netgate

    ALIX BIOS defaults to 38400/8/N/1, while pfSense serial defaults to 9600/8/N/1, if you get into the ALIX BIOS you may want to set that to 9600 to watch pfSense.

    If your terminal program isn't working properly, PuTTY is easy, free, and cross-platform.



  • ok, i tried with putty and the different baud rate but i still not working, i can't see alix bios. i think the cable is right, because with it i set up correctly several pfsense 1.2.2. i'll continue investigaste. thank you!



  • disconnect the cable from your Alix and short pins 2 and 3 together and see if what you type shows up on your screen.  If that doesn't work you have a cable or PC problem.  If it does work you still could have a ground problem in the cable or the PC's serial port may have a baud rate problem.  Also, your Alix serial port may be bad.

    Roy…



  • i think it's the motherboard. I have an Asus P5K PRO, i tried with a p4V88+ and it worked perfectly with same cables, hardware, so and software. I don't know why, because i have the same setting both in the bios and so.


Log in to reply