How do you get BandwidthD working?



  • I installed the package, and looked at the settings for it. I'm unsure of what values I need for most settings. When i attempt to start Bandwidthd in the services page, It states that It started, but when I refresh it's stopped.

    I get the following error in the system log:
    Dec 25 13:47:30 php: /pkg_mgr_install.php: You should specify a interface for bandwidthd to listen on. exiting.

    I made sure to set the interface to the LAN interface, but I'm still having issues starting it.

    I am using it on pfsense 2.0



  • I just attempted to start bandwidthd from shell, and get the following errors:

    ./bandwidthd

    /libexec/ld-elf.so.1: Shared object "libz.so.4" not found, required by "libgd.so.4"



  • Just installed 2.0b and had this issue myself, you can fix it by ssh'ing to the pfsense box and creating a symlink for this file against the newer .5 file:

    ln -s /lib/libz.so.5 /lib/libz.so.4

    Then you can run it manually (or use the GUI):

    /usr/local/bandwidthd/bandwidthd

    Bandwidthd maintainer should probably be notified of this issue to update their package.


Log in to reply