Error qwanRoot has no parent



  • Anyone know what teh error below is about and how to  fix it.

    php: : There were error(s) loading the rules: /tmp/rules.debug:18: queue qwanRoot has no parent /tmp/rules.debug:18: errors in queue definition /tmp/rules.debug:19: queue qlanRoot has no parent /tmp/rules.debug:19: errors in queue definition /tmp/rules.debug:20: queue qP2PUp has no parent /tmp/rules.debug:20: errors in queue definition /tmp/rules.debug:21: queue qP2PDown has no parent /tmp/rules.debug:21: errors in queue definition /tmp/rules.debug:22: queue DefaultUp has no parent /tmp/rules.debug:2



  • I'm about to format and start from scratch again since I'm plagued by this, and I thought I was alone. OK, tell me what did you do and let's see if we get anything in common.

    I run the traffic shaper wizard for the first time. I delete all queues except the two root queues. I renamed/created new queues. Once I'm happy with the queues, I press apply. I then see what you see in filter reload. Yikes I thought. OK, so I tried to do something smart. I remove the wizard, and rerun it, I get the 'default' wizard rules. I back up the traffic shaper under diagnostics.. I then manually modify the configuration to have the queues I want, and I then load it back. Got the same errors.

    So, now… I decided to do something simple. Just rename a queue after rerunning the wizard. I got the error.
    Rerun again, create new queue. Same thing again!.

    So, what now?! OK, maybe I messed something up. Thinking of going fresh, but this should never happen anyway right... I hope I can get the root of this... I tried to ask for help on IRC, but I got the feeling that I was alone in it... so yeah, conclusion, go fresh.



  • i wiped my settings and used the wizard many times with just the wizard it seems fine.
    The problem happens when i make any changes. Add a new rules or change something.



  • Yeb, same here. What good is shaping if I can't configure it the way I want. Btw, when you said rules, you meant queues?



  • Well, there may be a bug there, I guess.  On the other hand, your snide comment is not really helpful.  As written, the shaper wizard is good enough for most peoples' needs.  I would guess that needing to delete, create, etc a bunch of queues is not common.



  • i agree but as new games are out you need to add new ports and rules.



  • Well if it's there, it's meant to work.. and if it's not, it's either a bug or I'm doing something wrong… I hope there are others who can test/confirm this.

    Update:

    OK, did a fresh clean install.. what I had said earlier may have been inaccurate, i think there needs to be a rule for each queue else something goes frenzy.. I removed all the queues to start have my own rules, doing further testing now to confirm.

    Update 2:

    Further confirmations required, as it is right now, every queue must have at least a pair of properly (confirm again please) written rules.
    To test, I deleted all rules, got the errors. I added manually following the same format. The errors disappeared.

    Note to developers:
    The Apply Changes + Save can be a little misleading. Some sections after making changes you get the Apply changes box. (example, adding a queue). In many sections, we get this, so I have grown accustomed to pressing apply changes once I'm satisfied with them. However, when deleting rules, I don't get this "Apply changes" button, and since I'm already accustomed to it, I sometimes completely forget the need to press "save". Well, rather trivial, but i thought worth noting.


Log in to reply