Squid GUI "Custom options" Line feed problem …



  • If you add any options via the web gui to the custom options in squid the result in the squid.conf file is without line feeds.

    for example

    if i put:

    refresh_pattern -i exe$ 0 100% 999999
    refresh_pattern -i zip$ 0 100% 999999

    and i look at squid.conf it shows up like this:
    refresh_pattern -i exe$ 0 100% 999999refresh_pattern -i zip$ 0 100% 999999

    this is a problem? i am using firefox if that matters…


  • Rebel Alliance Developer Netgate

    Did you read the note under that box?

    You can put your own custom options here, separated by semi-colons ( ; ). They'll be added to the configuration. They need to be squid.conf native options, otherwise squid will NOT work.



  • so even with the ; they will still be one line. squid knows to separate the two lines?


  • Rebel Alliance Developer Netgate

    The ; is a trick to make it work. The parser in the squid package splits it on ; and makes it separate lines in the actual config.

    Just follow what it says, and it will work.



  • thanks that did work!

    on a side note; please tell me why there are lines for "delay_pools" when i have explicitly set all delays to off or rather left them at 0…
    all four boxes in the traffic management page are set to 0
    ever box below is unchecked

    so why are there delay_pool options in the file?

    ((i didnt want to start a new thread about this))


  • Rebel Alliance Developer Netgate

    I would start a new thread for that. I really don't know the answer and nobody would find that question in this thread. Your best chance at getting an answer would be a new topic with a more relevant subject line.


Log in to reply