Manual update issues



  • i just tried to upgrade to the 28th December snapshot but i face failure and error reported is as:

    Misc log:

    mount: /dev/ufs/pfsense1 : Operation not permitted
    cp: /tmp/pfsense1/etc/fstab: No such file or directory
    sed: /tmp/pfsense1/etc/fstab: No such file or directory
    umount: /tmp/pfsense1: not a file system root directory

    fdisk/bsdlabel log:


  • Rebel Alliance Developer Netgate

    Is this a full install or nanobsd?

    Are you sure you used the right upgrade file (and one of the proper size)?

    It may require a reflash in some instances, too, but those should be rare.



  • im sure the files r correct even the sizes and they r 1gb update images for nanobsd, i have been using them ever since without any issues, first time i see this error.


  • Rebel Alliance Developer Netgate

    You may need to reflash this time if you can't get the upgrade to take.

    If you haven't tried already, you may want to attempt the update from the console instead of the webgui.



  • i tried updating from console, thing went through and the alix restarted normal without errors but i upgraded to 28-Dec-2009 22:26 snapshot but doesnt show me that date anywhere even on system info page so is there any other way to check what snapshot im currently running?



  • uname -a shows the time of kernel compilation. Well I guess that they compile it with every snap….

    Mine shows 28th....



  • so it wasnt successful for me coz it shows 26th December so which means its not upgrading from console as well as GUI, atleast for me.



  • I needed some tries as well for the 28th build. It rebooted way too fast. And boom, suddenly it worked. The new build from 29th looks corrupt though, only 6.3MB in size…



  • i guess ill have to reflash which is the most boring things to do on a alix or might wait a while till few more things r solved in 2.0



  • upgrade wasnt working for me at all so i now did a clean install of nanobsd and encountered the following issues on the 30th dec snapshot.

    after i reflashed the CF and booted, it was all fine but the web configurator wouldnt start at http://lan ip so i had to assign the lan ip again and this time it would ask me if i wanted to revert to http for web configurator so i said yes which means on a clean install its suppsoed to be https for web configurator but after i reverted to http and tried that it still forwrded me to https and web configurator came live so on a clean install im not forwarded to https when i type http which might be a bug i guess.
    secondly, after the web GUI came up i restored the config and it said it would reboot which it didnt so i had to do that manually from the serial console after a while. once rebooted the WAN link etc came live and i was able to surf but the web configurator still wouldnt open, nor with http nor https, i tried assigning lan ip again etc but wouldnt work so did a factory restore and that would get it up but as soon as i restore my config, web config dies, rest every1 starts working.



  • currently i just cant get the web config to start even resetting to default password and even restarting it so some help would be greatly appreciated, only web config down, rest all up.



  • i cant get the web config to open from LAN but can access it from wireless which is bridged to LAN.


  • Rebel Alliance Developer Netgate

    Not sure if this might be some of your issue, but the webgui defaults to HTTPS now, so you should be using https://lan.ip

    If you still have issues that doesn't fix, I'd start a new thread for it since it's a different topic than an update issue.


Log in to reply