[IPSEC] not working on 2.0-BETA1 built on Mon Dec 28 06:59:27



  • 2.0-BETA1 built on Mon Dec 28 06:59:27 EST 2009

    IPSEC Log:

    Dec 31 15:30:51 racoon: ERROR: could not read configuration file "/var/etc/racoon.conf"
    Dec 31 15:30:51 racoon: ERROR: glob found no matches for path "/var/etc/racoon.conf"
    Dec 31 15:30:51 racoon: INFO: Reading configuration from "/var/etc/racoon.conf"
    Dec 31 15:30:51 racoon: INFO: @(#)This product linked OpenSSL 0.9.8k 25 Mar 2009 (http://www.openssl.org/)
    Dec 31 15:30:51 racoon: INFO: @(#)ipsec-tools 0.8-alpha20090903 (http://ipsec-tools.sourceforge.net)

    I get this message when I try to force reload:

    Fatal error: Call to undefined function vpn_ipsec_force_reload() in /usr/local/www/status_services.php on line 126



  • I just fixed the fatal error. The other error makes it sound like you don't have a racoon.conf, what do you get when you go to Diagnostics > Command and run:
    cat /var/etc/racoon.conf



  • the file is not here

    [2.0-BETA1] [root@pfsense.local]/var/etc(3): ls -l racoon.conf
    ls: racoon.conf: No such file or directory
    [2.0-BETA1]



  • can you email me the ipsec portion of your config? cmb at pfsense dot org  You can strip out any keys/certs



  • no config just try to active them with the checkbox


Locked