IP issues



  • OK, I'm having some issue putting new machines behind the pfSense RC1 firewall and having them recognized.

    IP configurations (no DHCP enabled):

    WAN : X.X.X.193 / 25, gw X.X.X.254
    DMZ (opt1) : Bridge with none, 10.1.1.1 / 24
    LAN : Bridge with DMZ, 192.168.2.1 / 24

    I successfully have machines using 1:1 NAT:
    WAN X.X.X.200 / 32 -> DMZ 192.168.2.200 / 32 - database server
    WAN X.X.X.201 / 32 -> DMZ 10.1.1.201 / 32 - web server

    Now, let's say I want to add an IP to the web server.  I give it 10.1.1.202, my ifconfig looks like this:

    inet 10.1.1.201 netmask 0xffffff00 broadcast 10.1.1.255
    inet 10.1.1.202 netmask 0xffffff00 broadcast 10.1.1.255

    Added the virtual IP: WAN / Single Address / X.X.X.202
    Added 1:1 NAT: WAN, X.X.X.202 / 32 -> 10.1.1.202
    Added the passthru rule: Allow, TCP/UDP, WAN, : -> 10.1.1.202 / 32 port 80, keep state, gw: default

    However, when I HTTP into the public IP X.X.X.202, I get a timeout, and nothing seems to be happening in either the state table or log with a reference to X.X.X.202.

    I'm probably missing something simple, but I'm racking my brains trying to figure out what it is.  Any help would be greatly appreciated.  Thanks!

    darius



  • Sorry to be this strict but RC1 is WAY TOO OLD to be supported. Upgrade to a recent snapshot or (even better) reinstall: http://pfsense.com/~sullrich/1.0-SNAPSHOT-09-22-06/

    A million things have changed since that version. Please report back if the problem still exists on the newest version.



  • Ok, no problem.  Just to verify - the XML config file is still compatible, right?



  • It "should" be.



  • DMZ (opt1) : Bridge with none, 10.1.1.1 / 24
    LAN : Bridge with DMZ, 192.168.2.1 / 24

    wai is the lan bridged with dmz ?, this will make from 2 subnets only 1?


Locked