Darkstat package issue. Installs ok, but link goes to weird address.



  • Hope this is the right place for this  ;D

    I tried to install the Darkstat addon package and it appears to install correctly.
    I refresh my browser and I see the link for the Darkstat Settings and the Darkstat
    link in my Diagnostics area, but when I click the Darkstat Settings, it brings up
    a page that gives me the option to choose WAN, LAN, or OPT1 and then save it.
    Saving it doesn't appear to do anything, and clicking the Access Darkstat sends
    me to a strange URL.

    http://192.168.0.2:81:666/

    I am running my pfSense on port 81 instead of 80, so I just assumed that it didn't
    take this customization into account. When fix the link in my browser and point
    it to

    http://192.168.0.2:666/

    I get a blank page error. I tried using the reinstall GUI option but it still doesn't work.
    Just wondering if anyone else has had this issue.



  • try removing the package
    set pfsense back to port 80
    install the darkstat package
    test it
    now move pfsense back to port 81

    this will make sure that all the links in the package are corect



  • I have same problem here. It happens when using non-standard ports. Same problem with packages: darkstat, ntop,…



  • I removed the Darkstat package, switched my Admin Web GUI to run on port 80 (default) and then re-installed Darkstat. It finishes okay saying it was installed properly and now the link looks like it is pointing
    to a valid port:

    http://192.168.0.2:666/

    But, I get a page cannot be displayed error. Since it appears Darkstat is running on another port on the router machine, do I have to make a rule to allow TCP port 666? Is that why I get no page displayed?

    Also, when I switched the port back to 81, it gave me the funky URL again.

    http://192.168.0.2:81:666/

    FYI..
    IPerf and NMap installed  without any problems using webGUI port 81.



  • Using 1.0-RC3b with nmap, openntpd and darkstat.  I am getting correct IP:port but page times out.  Under Services it always shows stopped even after starting service and message indicates that service has started.  I usually get the following in system logs after tryign to start the service:

    Oct 3 22:33:13 kernel: xl0: promiscuous mode disabled
    Oct 3 22:33:13 kernel: xl0: promiscuous mode enabled

    Any suggestions? Tried un-installing & re-installing as well as xml only install etc.



  • Did you configure it to listen on an interface? You at least need to hit save once at the config page after you selected the Interface to write the config file for darkstat.


Log in to reply