Error creating RRD graphs for Memory Utilization & QueueDrops.



  • I'm using the following version:
    2.0-BETA1 built on Fri Jan 8 03:48:57 EST 2010

    All other graphs appear to be working, but when I go to check out the RRD graphs for Memory Utilization and QueueDrops, they show an error and to check the logs and here is what I see in the logs:

    php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: Could not parse color in ''/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/system-memory.rrd-4h.png --start -14400 -e -60 --vertical-label "utilization, percent" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "`hostname` - System :: Memory - 4 hours - 1 minute average" --height 200 --width 620 -x "MINUTE:5:MINUTE:10:MINUTE:30:0:%H%:%M" DEF:"active=/var/db/rrd/system-memory.rrd:active:AVERAGE" DEF:"inactive=/var/db/rrd/system-memory.rrd:inactive:AVERAGE" DEF:"free=/var/db/rrd/system-memory.rrd:free:AVERAGE" DEF:"cache=/var/db/rrd/system-memory.rrd:cache:AVERAGE" DEF:"wire=/var/db/rrd/system-memory.rrd:wire:AVERAGE" LINE2:"active#:active" LINE2:"inactive#:inactive" LINE2:"free#:free" LINE2:"cache#:cache" LINE2:"wire#:wire" COMMENT:"\n" COMMENT:" minimum average maximum current\n" COMMENT:"Active. " GPRINT:"active:MIN:%7.2lf %s " GPRINT:"active:AVERAGE:%
    

    Of course, this is repeated X number of times for each set of graphs…



  • I'm having the same issue here…
    Running on pfSense 20100325-1036


Log in to reply