Alternate DNS for squid doesn't work



  • I want to use third party DNS provider for better management of internet browsing through squid proxy. So I enter DNS servers in the "Alternate DNS" string in squid settings, but it doesn't seem to work - my DNS provider reports no activity from my IP. So, if I enter a random IP in DNS string in squid, everyting still works well through proxy, it seems this setting doesn't matter at all.
    How can I configure squid to use the nameservers I want?
    I use pfsense 1.2.3 release



  • Do you have reasons for not setting them as your DNS in the system/general page?  I find that these do propagate to Squid.  Also, if you were editing squid.conf this file gets rewritten from squid.inc.  Make your changes to /usr/local/pkg/squid.inc instead and it just might work.



  • I want only proxy users to use this third-party DNS provider as it is not very fast but offers extended DNS management capabilities.
    Also, I did not edit squid.conf or squid.inc. Just wonder why the settings don't work through GUI…


Log in to reply