2.0b Upgrade from 1.2.3 console "…....." never finishes



  • I ran the upgrade from console option last night, the http://snapshots.pfsense.org/FreeBSD_RELENG_8_0/i386/pfSense_HEAD/nanobsd/pfSense-2.0-BETA1-1g-20100107-0713-nanobsd.img.gz  file downloaded fine and matched the MD5.  PFSense asked me if I wanted to proceed with the install, I answered "y" and pressed enter.  That was followed by ~10hrs of "…......" on the screen with no progress.  When I awoke this morning I gave up and reset the box and it booted back into 1.2.3 just fine.

    Question:  Is there a temp folder I need to clean out?

    Is there an alternate log that I can look at to see what failed?

    I may try upgrading to 2.0 again using the same or another method, but was curious about the above.  Thanks.



  • I have the same problem as well. I checked the GUI shortly afterwards and the alert pane said there was not enough free space (~990Mb needed, ~440Mb avail) or something along there. I have a 1Gb CF card and was using the 1Gb distro.



  • I'm not sure whether this is related or not.  I initially copied the 1.2.3 512 MB nanobsd release to a 512 MB card and upgraded to a 2.0 beta build with no issues, but then I cannot upgrade from the 2.0 beta builds to another 2.0 build, getting an error about running out of space.  When I want to upgrade, I need to boot up the slice containing 1.2.3 (which requires restoring the old config, I think because I started out with a fresh config on 2.0) and then upgrade from there.  I think I tried recopying 1.2.3 to the card and upgraded to another 2.0 build sometime, and still encountered the same issue when upgrading from one 2.0 build to another.  The upgrades from 1.2.3 release to 2.0 builds always works fine for me, however.



  • Is anyone else seeing this? Is there any debug data I can gather for the pfSense team to help debug this before the 2.0 release?


Locked