Squid and dns redirect



  • Hello,
    on pfsense 1.2.3 with squid enabled (default settings) I'd like to setup the squid service so when I type an incomplete url (ie: "slashdot" instead of "slashdot.org") I'm redirected to the right website/google, like it happens in firefox (wrong url -> google search -> correct url or google results). As now I only get the squid error page that the url is incorrect.
    I'm new to squid and probably I've searched for the wrong terms, but I've found nothing that can help me on google.

    TIA

    giuliano



  • http://www.opendns.com/ might take care of this for you…



  • Thanks,
    it seems to work fine. I've had to use internal DNS and setup this DNS to forward any external query to opendns

    giuliano

    edit: it seems my users hate opendns… everyone wants google as the search engine for invalid urls... any other suggestion ? the dns server is a bind server

    thanks



  • You can disable their typo correction and proxy feature if you go to their website.  This will make their DNS servers return the proper NX response, but then you might be back where you started.  It will also disable their content filtering unless you are a paying customer.  Alternatively you could try using some of the other free DNS services which do not hijack results like Google…8.8.8.8 & 8.8.4.4 or 4.2.2.1-4



  • thanks, I'll try with google


Log in to reply