Layer 7 shaping not working or am I just being a n00b?



  • Since I did not get any joy with any of the Traffic Shaper Wizards as per previous posts, I decided to try and create some by hand.  Problem is - even though I did add RDP and SSH to Layer 7 action queue to my qHigh queue, when there is lots of traffic on RDP/SSH I never see any data in the queue monitor in any queue other than qDefault.  Why is this?  What do I need to do to implement a simple traffic shaper where I prioritise RDP/SSH traffic?



  • Some screenshots of my current setup.  If I did this completely wrong please point me to an article on how to set up pfSense 2.0 traffic shapers:

    ![Screen shot 2010-01-16 at 10.53.01 .png](/public/imported_attachments/1/Screen shot 2010-01-16 at 10.53.01 .png)
    ![Screen shot 2010-01-16 at 10.53.01 .png_thumb](/public/imported_attachments/1/Screen shot 2010-01-16 at 10.53.01 .png_thumb)
    ![Screen shot 2010-01-16 at 10.53.30 .png](/public/imported_attachments/1/Screen shot 2010-01-16 at 10.53.30 .png)
    ![Screen shot 2010-01-16 at 10.53.30 .png_thumb](/public/imported_attachments/1/Screen shot 2010-01-16 at 10.53.30 .png_thumb)



  • Looking at the source code for  /usr/local/www/wizards/traffic_shaper_wizard_multi_lan.inc it seems like the protocol based shaping would create floating outbound firewall rules.  However after running the traffic shaper wizard (I deleted the above rules and tried again) I only see two entries under Floating - both for qVoIP.  None of the other protocols I selected (RDP, VNC as High Priority) made it to this floating firewall ruleset.


Locked