Does transparent proxy with Squid 2 on pfSense 2 BETA work?



  • Asking since I upgraded pfsense 1.2.3 to 2, and after the upgrade my transparent proxy does not seem to be working.  I can use the proxy directly, but in transparent mode the HTTP requests do not go through the proxy.  I have a default configuration - only selected the LAN and WiFi interfaces, enabled Allow users on interface and Transparent proxy but my traffic bypasses it.

    Any ideas?  (I know because nothing is logged in /var/squid/log/access.log)



  • See the basic funda is Squid will work unless you dont use MULtiWAN.
    Because we are still in beta stage.the upgrading might have messed up with squid config.
    Just configure it once again. IT should work.



  • @rudraansh:

    See the basic funda is Squid will work unless you dont use MULtiWAN.
    Because we are still in beta stage.the upgrading might have messed up with squid config.
    Just configure it once again. IT should work.

    I did a factory reset about 4 times and even built up everything by hand - no luck.  I did notice that after installing squid (with no errors) I do not see squid in the installed packages list.  It does however appear in the menu and I can manipulate its settings.

    Just explain to me - I do not have multiple WANs.  I have one WAN, one LAN and one OPT1 (for Wireless).  Is this config currently supported and working in pfsense beta 2?


Locked