Embedded 1.2.3 on Laptop



  • Hi all!
    I have been using PFsense 1.2.2 for quite some time on my D600 laptop and I decided to make a jump to the new 1.2.3 version.
    I wrote the 2gb image file to a 2gb CF card with a USB adaptor using Windows 7 and Physdiskwrite. All looked good, but the system is hanging on

    BTX loader 1.00  BTX version is 1.02
    

    I tried connecting with a console cable and Putty but no joy.

    Any advise? Does that mean that it is not booting or that it is waiting for a console connection?



  • Are you aware the embedded version switches console output to the serial port very early in the boot process?



  • Yeah, but unless I am doing something wrong I get nothing from putty after setting it to COM1



  • Not sure what you mean by a "console cable". You almost certainly need a crossover cable (sometimes called "null modem" cable)  where Tx and Rx of one end connect to Rx and Tx (respectively) of the other end.

    Tx  –--\  /----- Tx
                   
        Rx  ----/  ----- Rx

    I think the serial port on your computer running Putty should be set for 9600bps, 8 bits, no parity.



  • I am using the cable I used before on 1.2.2. It is a cable that would be used to connect to a Cisco device with an adaptor on one end to convert it to serial, so it should be a null modem cable.

    Those are my putty settings and in the window I just have a blinking cursor, I get the same result with no cable in at all.

    It could be my cable was twisted or crushed, I will try to get access to another cable. Do you happen to know what should be shown on the device at the point that it is ready for a serial cable?



  • From what I'm reading it seems like the system isn't yet at a point that it is ready for a null modem connection. Is there any way of turning on any kind of boot logging to find out why it doesn't get past this point?



  • It might be worth a shot to make sure the laptop has the latest BIOS. You could also check the forum for the notes on getting nano to work on a WRAP- your issue could be similar.



  • I know little about the embedded system startup.

    Perhaps you could try booting the 1.2.3 live CD on your laptop for comparison.

    It might also be worth trying to boot off the compact flash card on another system but you will need a different system again if you want to monitor the console output.

    The problem reported in http://forum.pfsense.org/index.php/topic,22178.0/prev_next,next.html#new has at least superficial resemblances to your problem.



  • @dotdash Getting nano to work on a WRAP? I'm sorry but that totally over my head.

    @wallabybob Great suggestions! I'll grab a CD Rom drive from work tomorrow and try a live CD. Hopefully that'll shed a little light on this.



  • @madelk:

    @dotdash Getting nano to work on a WRAP? I'm sorry but that totally over my head.

    WRAP and Alix re both embedded systems with no video interface - hence have serial console. "Nano" is the FreeBSD targetted to embedded systems. Its possible the WRAP notes might have some hints for debugging the sort of problem you have.



  • The BIOS of the WRAP boards has an issue booting nano. They worked fine with the old embedded. The workaround is to change the boot image to CHS from packet mode. It's possible your laptop BIOS has a similar limitation. Here is the information: http://doc.pfsense.org/index.php/NanoBSD_on_WRAP



  • Hy! I had issues with pfsense when I try to connect from putty.
    I use hypperterminal from windows.

    serial setting 9600 8biti on the client, not pfsense(there should be com1 or irq4 set up in bios), and use a normal serial modem cable.


Locked